Cannot SSH into Jetson Nano from PC (Same network)

I tried to ssh into my Jetson Nano from my PC (running Ubuntu 18.04) using WiFi on the same network a few days ago and it worked. However, when I tried doing it today, I’m no longer able to do so. I connected an EdiMax WiFi adapter to the Nano and turned on WiFi on my personal hotspot and made sure that my computer that I was sshing into the Nano was also on the same network.

When I tried to ping the IP address of the Jetson Nano, it returns Destination Host Unreachable. When I tried to ssh in, it says no route to host. When I traceroute the Nano IP address, it also says that host is unavailable (!H). If someone could point out how I can rectify this, I’d be very grateful. Thank you!

Is your jetson nano able to ping any other devices that are connecting to the same wifi?

Unfortunately, I can’t ping any of the devices from my Nano (that are one the same network).

And are you sure your jetson nano able to reach out to external network like google? Is it able to ping

Yes I am able to ping from my Nano

Do you have any control panel application of your house wifi to make sure these two devices are really under the same domain?

I am using the personal hotspot from my mobile as the WiFi. Is there any application that I can use to check the domain?

Sorry for the late response, is this still an issue to support?


The above says that whatever the problem is that it is out of the hands of the Jetson. It is still possibly a fault with the Jetson if for example the interface providing the connection went down, but anything else tends to be part of the local network (or DNS if using that). On both host PC and Jetson these commands would provide more information: