Can't connect to


I can not connect to ?
I have tried all the possible diagnostics and proved my MAC’s USB is working fine, but NVIDIA still can’t connect.

(1) I had written image for my microSD card following the “Getting Started with Jetson Nano Developper Kit”, and it working fine for “Hello AI World”.
(2) Do you think I need to re-image the microSD card for the course “Getting Started with AI on Jetson Nano” ?

PS: My Jetson Nano is working fine for “Hello AI World”, but it is not working for the course “Getting Started with AI on Jetson Nano” ? I did follow all the hardware setup for headless device setting, Do you think the image is the problem?

Please help!

Jong Lin

1 Like

you just need another microSD card

SD image, not sd card


I don’t understand the meaning of “another SD image”?

Do I just need to add a different image mention in the course, or I have to erase the old image and create the new image from the course description?


Jong Lin

Can I still use my normal SD card image and just add the different image for the free course?
or, I have use another new SD card and do the setup with the link described in the course?

Jong Lin

Image means whole whole content of sdcard, so partitions, os and filesystem.
You cannot add image to image, but you can install missing packages, if you know which one you are missing. I don’t have a list of of them.
Other than that, you can either rewrite your current sd card, but lose data from old image.
Or you can flash the course image on another sdcard, use that card until you finish the course, and then revert to using orignal sdcard you have now.

Also note that to use new JetPack 4.2.1, you won’t be able to upgrade old 4.2.0 image. I was told, devs are working on being able to upgrade with apt-get, but it won’t be possible with 4.2.1 yet.

You need to make sure you use

I finally got through this. A few advises:

  • make sure you got ainano_v1-1-1_20GB_200203B
  • check it in CMD with \ping if something lost, unplug micro-USB and plug and check again
    now try the link. It works for me
1 Like

Hi, is there a reason why one cant connect successfully using the latest jetpack 4.4 jetson nano image? I have repeatedly installed this successfully on my nano but headless connection never works. I’ve tried several browsers, and confirmed the usb cable is working. My laptop gets the ip address and can ping
I see that most people who ended up resolving this, say they had to download ainano_v1-1-20G… , but why doesnt the other image work for this ?

The entire box is a pain in the ass.

The Nano DLI image being referred to includes a JupyterLab server that is automatically started after boot, hence your web browser can connect to it. The stock JetPack image doesn’t start such a JupyterLab server, but you should be able to SSH into the board at with the JetPack image. Your web browser isn’t for SSH session, instead use an SSH client like putty (on Windows) or just ssh (on Linux).

Also, the Nano DLI has since moved to running in a container, where the container runs the JupyterLab server once the container gets started. The l4t-ml container also auto-starts a JupyterLab server when the l4t-ml container is started.

Thanks, Dusty. Found this response just now.