CDC ECM driver on windows

Hi, super noob here,
just working through the initial headless first boot.
having some trouble getting access to the nano from my win 10 pc,

in device manager i am finding that on the other devices tab, the CDC ECM has a driver error, it appears that there is a clash with the usb / ethernet protocol which appears to be preventing me from accessing

anyone have any ideas where i can get the drivers for windows to sort this?

Not much help, except to say you’re not alone - I too, a Jetson Nano noob, am having exactly the same problem!

Upon connecting the MicroUSB I do see in the Windows Explorer a new entry called “L4T-README” and that opens successfully with several README files. But like @brendan4418m I cannot access 192.168.55. In a Windows CMD window I cannot ping

After poking through the support forum I found the problem.

I downloaded the wrong SD image. As best I can tell, there is a specific Nano Ubuntu image for the course, dlinano_v1-0-0_image_20GB that enables the JupyterLab window at

I earlier had installed the “Jetson Nano Developer Kit SD Card Image” from the startup pages. It runs fine, but does not open up 192.168.1:8888 to the JupyterLab.

Lesson learned.

Hi Bill,

thanks heaps for that info. ill have a go now and see what happens fingers crossed!!!

Am I the only other person also having this issue? All online searches point to this thread. I’ve tried it on multiple windows 10 machines and the CDC ECM driver is not found by windows? Is there a place to download this driver on Nvidia’s website? From what I can tell, this is not included with windows. Thanks!

1 Like

Having the same issue and not finding a driver with any search. Microsoft does not make a default driver available.

1 Like

I did have the issue mentioned above. And like others, noticed the missing ECM driver that thought that must be the problem.

But it wasn’t.

The problem was I was running the wrong Jetson Nano image.

I was running the image the “Jetson Nano Developer Kit SD Card”. Made sense and booted up just fine. But I couldn’t log into the port and had the ECM driver issue.

Once I installed the correct image for the course, the DLI Jetson Nano image I was able to log into the Jupyter Lab and start working through the course material.

You can find the correct image for the course via this link:

Don’t bother searching for the ECM driver. It isn’t going to help you. The correct image will.

Thanks @bill.hohensee I thought I was going crazy for a quick minute! Downloading now.

Did not work for me unfortunately. Still shows the device as a USB mass storage device only (D: drive). No Ethernet device.

After disconnecting my Windows machine’s Ethernet cable, the device becomes available (but cycles between connected and disconnected).

Additionally, now I can’t access the course material :-(

Any ideas on alternatives to this? Give up on headless mode?

I used the correct image, I could connect to JupiterLab logon page by, but the Launcher did not appear on my Windows7 PC.
The Launcher appeared on the Windows10 PC.
First, I thought this was due to no CDC serial and ECM drivers on Windos7, but the device manager of Windos10 says CDC ECM driver is not installed also.
How can I run JupiterLab on my Windows7 PC?

Thanks @bill.hohensee,this image file solved my computer’s communication problem.

1 Like

I had more issues with CDC ECM, and suspected it’s caused the network settings. I found this post which fixes it:

Gives me connectivity now to

Not sure if its the same issue but I am having issues with CDC NCM, appears I am missing a driver