Headless Jupyter mode in free nano course not working.

Nvidia provides this free course for the Nano I found on the start page for the nano.

I am trying to get through the first part which emphasizes on setting up the nano in headless USB mode. Before this, I was just messing about with it on a screen and keyboard. But I wanted to do it based on the course-work. I tried doing it and it didn’t work. Then I tried rewriting the SD card with a fresh install. Still not working. I followed the instructions in the course exactly. The first time I was able to see the nano as a USB device and I could ping it’s IP address. I could even ssh into it. But jupyter isn’t showing up. What’s going on here? Is this course outdated?

1 Like

Hi Cat5,

Did you try to access the by putting http://192.168.55.1:8888 or https://192.168.55.1:8888?
If that was https you were using, can you try accessing http://192.168.55.1:8888?

I think I’ve figured out the issue. I believe it is due to me using the wrong SD card image. I used the normal one in the Jetson start page. There is a different one linked in the course and my guess is it has more stuff set up. Thanks for the help will let you know once I’ve confirmed.

Just for future visitors. Using the addresses you gave did not make a difference in my case.

Alright, it’s working now.

To anyone else having the same issue, it’s worth checking that your USB cable is actually data-enabled. Mine wasn’t!

Thanks! you save me a lot of time.

Hi Cat5,

I have same problem. I have an SD card image work for “Hello! AI word” from the Jetson start page. But this SD card image can’t work for the free course.

Do you just add the difference image or you just erased the old one and reinstall the new image requirement from the course?

Thanks

Jong Lin

Jong Lin,

I just erased the SD card and installed the correct SD card image. Of course be sure to backup any important projects or data you created.

If for some reason you are unable to install a different image then the alternative is to setup the required packages manually. It’s not easy but it’s possible and I believe there are install scripts available in the SD image git repo. But obviously just rewriting the image is faster and less hassle.

Best,
Ziad Arafat

Just a little upset that it could mean lots of work for using the same USB card.
I think I will use another SD card for the course.
Thanks Cat5 for help.

Cheers for that…timely advice.