macOS Headless Jupyter mode in free nano course Finally working.

I’ve flashed the dlinano_v1-0-0_image_20GB image onto my 256GB SD card. I’ve followed the steps provided in the course.

  1. Insert the 2-pin jumper across the 2-pin connector, J48 adding the DC power first
  2. Connect your DC barrel jack power supply (5V/4A)
  3. A green LED next to the Micro-USB connector will light as soon as the developer kit powers on. Wait about 30 seconds.
  4. Then connect the USB cable from the Micro USB port on the Jetson Nano Developer Kit to the USB port on your computer.

I get a L4T-README mounted on my desktop but I have not been able to connect via

I am only able to connect to that address when adding the keyboard, mouse, and HDMI cable via the chrome browser installed on the nano sd OS. Can someone help me figure this out.

Thank you

Hi ccora,

Is your host PC able to ping If the usb device mode is not set up successfully, then there would be no such interface.

Tried to ping (Request Timed out) Received 0.

I read your USB Dev Mode TXT file and it states that the Mac Operating System does NOT SUPPORT RNDIS devices. I had to install HoRNDIS: USB tethering driver for Mac OS X in order to get this thing running (am now able to PING and connect). Is there a better solution to this on the Mac? I’m not to sure how I feel using this 3rd party KEXT file. It’s working now but I would like a solid solution from NVIDIA on how to get this done.

NOTE: Could not login in via the safari browser. I was able to login using the Chrome and Brave browser.

Thank You!

I’m having the exact same problem but it happens in mac and windows. In windows it detects the usb device as a storage unit. In mac it does not detect it. I tried installing HoRNDIS: USB tethering driver for Mac OS X but that didn’t work, I can ping the device now but it won’t show Jupyter server in neither safari or chrome. It’s not a cable issue since I use it in several other devices.
What else can I try to rule out?