Connecting Jetson Nano to internet

Hi,

I am having some trouble connecting my Jetson Nano to the internet.

The procedure is to connect the Jetson Nano to my PC via an ethernet cable, and share the pc’s WIFI connection.

Weirdly, it worked when I was in an other place (with an other Wifi), but not where I am now.

What I already did:

  • Edited the etc/network/interfaces file with :

auto eth0
iface eth0 inet static
address A
netmask B
gateway C

  • Edited the etc/default/networking file with:

CONFIGURE_INTERFACES=no

  • On my home PC:
    In the Network and sharing center:

Wifi: selected « Allowing other network users to connect via this computer Internet connection »

Ethernet:
In IPv4:
Use this IP address:
IP Adress C
Netmask B

I also used the command lines « sudo reboot » and « sudo service networking restart » after.

Any help would be much appreciated !

@rose.louis.mail I think you’re describing a bridged network connection. You should only need to configure the bridging on your windows machine (I assume it is one, since you describe “Network and sharing center”)
There are a number of guides which generally describe the same Windows GUI procedure,

You should let the DHCP server manage the Jetson’s connection if you’re switching between networks (home, work, coffee shop).

If I misunderstood your goals, let me know!

Hello @fhaibach.

Thanks for your input.

I was actually describing a ICS setting (Internet Connection Sharing), where the host PC becomes a router, and not a passtrough as in a Bridge Network connection.

Both procedures could suit me, as long as I do access internet on the Jetson Nano.

I followed the turorial you sent me, and it worked fine up until the “regain internet access” part.

The Bridge just does not connect back to the network, despite putting the correct static IP address, as requested.

I should precise that I attempted to bridge my Wifi connection to my ethernet connection.

Any help would be much appreciated.

Edit : I also follow this tutorial (Join WiFi and Ethernet Together To Share Internet - Bridging Connections - YouTube), which basically describes the same procedure as the tutorial you sent me.

The result has been the same.

Maybe I should mention something weird :
The IP address given to my computer by the network is 172.20.233.153, and the netmask is 255.255.252.0.
But, when putting this same address as static IP on the bridge, the TAB-autocompletion of the Netmask line gives 255.255.0.0.

I tried both (this one, and 255.255.252.0), and none works.

FWIW since I am not a network admin, the netmask looks unusual to me. Maybe your network is a larger one with more-than-typically capable equipment and administration. The netmask shouldn’t prevent your Jetson from accessing your gateway if the gateway is in the lower range of addresses, like xx.xx.xx.1 . Get to know your network admin! They’re usually friendly and appreciate helping.

I have a wifi dongle for this purpose, which I use on my personal Jetson. You might choose a usb dongle from this list WifiDocs/WirelessCardsSupported - Community Help Wiki . I have a Panda PAU05 which “just works” but has problems with maintaining connectivity with interference - good enough for updates but bad for remoting into the Jetson. I still consider it worth the $$ spent.

Thanks for your answer.

I actually also bought a Wifi Dongle, the D-Link DWA 131 E1. Can’t seem to make it work though, as I can’t access internet on my Nano to install the driver …

solution? “sneakernet” using usb flash drive
With linux and wifi dongles, you need to be sure the chipsets have kernel drivers for plug-n-play. Panda and ASUS seem to have higher levels of compatibility.

Your original post is mostly about issues with Windows networking, with the Jetson as a client. Consider fixed ip’s for both and see if you can ping from one to the other. On the jetson, you’ll find ifconfig (temporary) and /etc/network/interfaces (permanent) to be your good friends. Once you have that 2 machine network running, you can try to bridge/ICS.