Ethernet will not connect

I am trying to set up an internet connection for my Jetson Nano, I am not using an external WIFI component, just connecting my ethernet cable directly to my home wifi. When I do this, the Jetson Nano will continuously try to connect and never actually connect. I have already re-installed the OS, fixed the Time built-into the Nano manually and nothing will work. Is there any advice I can get along these lines? Thanks in advance!

I guess you are talking about a router but not a “home wifi” right?

Sounds nothing related to reflash or driver level thing. Have you tried other ubuntu host PC to do the same things in your home beofre?

Could you open a terminal on your jetson and check if anything new printed to your “dmesg” command after you connect the Ethernet cable to your jetson?

please share me the log you saw but not just such description…

The order here is important… If the end of the log is link is not ready, then link is dead.
If the end of the log is link becomes ready then link is alive…

Here are the results

Looks like the link is up. What is the result of ifconfig command now?


Here are the results, whenever I try to connect to the network it shows “connecting” and then I get a message “disconnected” after it fails to connect.

The interface is up. Are you sure your router will assign a IP to the device connected to it?

Your question is already not related to Jetson. Maybe you can search it over the Internet first…

I will suggest @WayneWWW’s question about the router assigning IP is the next thing to check. I will point out that the ifconfig reveals nothing unusual regarding errors/collisions, so on, and that it is basically functioning. There are bytes sent and received, which are approximately correct for a DHCP request and a response.

Many routers have intentional security restrictions. Is it possible your router requires a MAC address to be entered before it allows connection? Is there anything unusual about the router itself, e.g., if it is part of a company router, then no doubt it has security on it.

Link up/down could be related to signal or hardware issues, but the ifconfig reveals nothing out of the ordinary so far as what drivers see or reveal. Routers have admin login, and logs. You can go to the admin web interface of the router and get the equivalent of the dmesg at the Jetson side. Knowing what the router thinks is wrong is the next step.

Yes so I am trying to check that, but unfortunately it is my dad’s network so I do not have direct access to it right now. My dad has been helping me trouble shoot and we managed to establish a manual connection using IPv4, but whenever I try to use DHCP, the router does not receive any messages from the Nano, at least the MAC address does not match,

There are bytes showing up in both sent and received. This is presumably due to a DHCP request and a denial in response. There are no other forms of error, and so it is about 99% certain that it is the router itself which is sending back the failure. I’m guessing that your router needs to add the Jetson’s MAC address to its list of accepted addresses.

My dad sent me some of the logs and it does not report the eth0 MAC address that I am seeing when I run ‘ifconfig eth0’, he added the address that the Nano is reporting and it did not affect the connection either.

Can you examine the last of the router log entries? This is for reference. Then plug in the unpowered Jetson to the ethernet. Refresh the log, and see if anything is added new. If it is, post that here. Then boot the Jetson. Run ifconfig to verify eth0 has some bytes sent and received. Refresh the router log, and see if something new is printed. Post what is added as a result of booting the Jetson and getting those bytes sent/received showing under ifconfig.

Note that ifconfig itself won’t cause any traffic. You might try (after the logging steps) to run 'sudo dhclient" and verify if the bytes sent change, along with bytes received changing. Or if perhaps an address shows up. Also see if router logs show up from the dhclient command.

One other possibility is that the router is providing only IPv6 addresses, and maybe (that’s a very “tiny” maybe) the Jetson is only configured to work with IPv4 addresses.

We just tried this and my dad says he still isn’t seeing anything on the network. Not really sure what else to do, everything that is physical we’ve troubleshooted extensively and I don’t know enough about these protocols to read tcpdump or even these logs - he keeps insisting that the Nano simply isn’t showing up on the router logs no matter what I do.

How is the wired ethernet connected? For example:

Jetson->switch->router->switch->other PC

# Or maybe:
Jetson->router->switch->other PC

Basically I’m wondering about the exact topology of devices. Is it possible to test with the Jetson directly plugged into the router if not already set up that way? There are bytes being transferred, something is working, but it is odd the router doesn’t see it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.