Cann't connect Internet: Did not find a connection with UUID(null)

Hi everyone! My Jetson Nano can not connect Internet via Ethernet cable. So I can not import any online library for my projects. I tried to reflash OS but it didn’t work. Anyone has solutions or workaround? Thank you!

Are you connected to an ordinary router? Does the router have any security which might require entering the Nano’s MAC address?

What do you see from the Nano for these commands: “ifconfig” and “route”?

Please see these photos: https://photos.app.goo.gl/zUY1XG9bSkc3782U7
Yes. It’s normal router which doesn’t require entering MAC.

The wired ethernet is not even detected. You might post the output of “dmesg | grep -i ‘eth’” and “dmesg | grep -i ‘eqos’”. This might offer hints at failure of software versus hardware.

Either way the next step will probably be to try flashing again, but if flash fails again we’d be looking at that debug information anyway.

  1. I tried those commands you suggested. Here’s the output: https://photos.app.goo.gl/JRAxxxQbKnYFurbD7

  2. I flashed the second time but still not connect Internet via Ethernet.

It is strange to see absolutely no listing of eth0 from ifconfig, and yet see grep of dmesg indicating there is ethernet hardware. If multiple flashes still do not show eth0 from “ifconfig”, then it is probably time to RMA. If possible, and if you have the ability, then you might try plugging the wired ethernet in to some other router just to see if the issue is specific to router (routers can be set to ignore MAC addresses they don’t know, but this wouldn’t cause the interface to show as completely missing in “ifconfig”, so I’m not sure if testing on another router would matter).

Better sharing the full dmesg.

Do you see r8168 driver in your log?

[    2.370443] r8168 Gigabit Ethernet driver 8.045.08-NAPI loaded

Thank you guys so much for response! It is time for RMA.