Wired network not working in jetson nano

initially ifconfig listed inet6 address, so managed to disable ipv6.
later ifconfig no ipaddress is assigned.

added eth0 to /etc/network/interfaces then ifconfig listed:
eth0 with no ip address
eth0:avahi with inet 169.254.9.165
lo with inet 127.0.0.1

tried static ip as well didnt work.

need help.

IMG_20190721_082507.jpg

IMG_20190721_082507.jpg

route command shows empty

The 169.254.9.165 address is a dummy address for an interface which never received an address, and yet needs an address.

The ifconfig output shows a small amount of data went out, roughly what a DHCP request would require. Only two packets are received, and so it looks like DHCP response did not assign anything. There were no errors of any kind, and so hardware seems to be ok.

The missing “route” output is consistent with a lack of DHCP response.

Some routers might only give you an IPv6 response, but I suspect that unless your situation is somehow special this isn’t the case. Most likely network setup related to disabling IPv6 did something other than what you expected, but you still have to check your router and see if it saw the MAC address 00:04:4b:et:40:df, and if it did, see if it has a log or note on the assigned address. Perhaps it is something as simple as the router rejecting MAC addresses it doesn’t know.

Thanks issue is resolved. it was my router problem.
Router had disabled the LAN ports.