No internet connection

I just installed the ubuntu image. But when I connect the ethernet cable, there is no internet connection. Tried different cables and ports. I have also added the following lines to /etc/network/interfaces

auto eth0
iface eth0 inet dhcp

then type: sudo ifup eth0

but still no internet connection.

I have also tested the Edimax 7611ulb wifi+bluetooth adapter, still no luck
Can anyone help?

Hi,

Pls refer to another topic. Try the attached driver first.

https://devtalk.nvidia.com/default/topic/1049303/jetson-nano/jetson-nano-wifi-/1

The thing is my Jetson Nano cannot access to the internet at all. I won’t be able to use: sudo apt update or sudo apt install …

I notice the ethernet port is blinking orange.

And the output of ifconfig eth0 shows:

jetson@jetson-desktop:~$ ifconfig eth0
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.55.223 netmask 255.255.255.0 broadcast 192.168.55.255
inet6 fe80::c309:fb62:2989:4d41 prefixlen 64 scopeid 0x20
ether 00:e0:4c:68:01:95 txqueuelen 1000 (Ethernet)
RX packets 203 bytes 18662 (18.6 KB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 44 bytes 7655 (7.6 KB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 148 base 0xe000

Hi, shaunlipy

Could you attach the kernel log after boot up the system?
Which version are your SD-Image?

The latest version is jetson-nano-sd-r32.1-2019-03-18.zip from the followed link.
https://developer.nvidia.com/embedded/jetpack

From your log I don’t see something abnormal. This the log I captured from my Nano board.
The eth0 node is automatic create after boot up. Also you can check from your router to see if there is a real connection there.

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.172  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::e07:2a7a:ce82:cba  prefixlen 64  scopeid 0x20<link>
        ether 00:04:4b:e3:f8:61  txqueuelen 1000  (Ethernet)
        RX packets 359  bytes 225622 (225.6 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 384  bytes 44844 (44.8 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 148  base 0xe000

Finally found out the bridge connection is messing up the internet connection. I have to disable and delete it .

Good news.

I had a very similar problem which I post about here.

In my case the Nano’s eth0 is up and fully accessible within my LAN (I can SSH to it) but the Nano can not ping outside addresses beyond the router (while all other hosts can).

Like the OP, I also tried to cut down the cruft in the routing table but I was never able to successfully get that to work. Can anyone provide an explicit procedure which will cleanly remove any conflicting routes? Or some other way allow the Nano to work properly with its networking port?

Thanks

1 Like

What is the output of “ifconfig” and “route”? FYI, if you have more than one default route, then a “sudo route remove default” removes the route with the highest priority first (the lowest metric). If you save a copy of the route and accidentally remove too much, then you can add a default with the one you want. There are various tools for adjusting those in a GUI as well (e.g., if going through NetworkManager, then “sudo nm-connection-editor”).

If your router is not set to respond to DNS queries, then it might be a case of needing to tell the router what your MAC address is (a router will usually default to allowing any device, but security settings can be told to allow only known MAC addresses).

Thank you for the good suggestions linuxdev. I was sure this had to be a configuration problem because we have a normal Verizon Fios router with about a dozen hosts all working just fine. But when I went to provide a look at the route and ifconfig, I first did a quick ping to confirm it didn’t work – but it did work! I changed nothing. Did nothing. Now attention has shifted to the router. I logged into that and there is a setting under “My Network” that shows hosts and on the host in question I saw there was an option for “unblock host”! Obviously I had not previously logged into the router to (partially) block this host. That’s just incredibly weird. So a heads up to Verizon Fios users that the Verizon router may not like Jetson Nanos (sometimes). Hope nobody else has this problem but if they do, I hope this helps.