Internet connection error


I’m trying to setup a Jetson Nano, I want to use an old version with CUDA 10.0 and cuDNN 7.x due I need to use Darknet (and Darknet is too slow with CUDA 10.2 and cuDNN 8) so I’m trying to use Jetpack 4.3 or older.

The problems is with Internet connection, it isimposible connect to Internet via Ethernet or WiFi. If I plug the Ethernet whire nothing happens. If I use a wifi dongle the Jetson detects it (with lsusb command) but it is impossible stablish a connection. If I write “ifconfig” wlan0 doesn’t appears.

Currently the Jetson Nano is running Jetpack 4.3. I tried older version and always happens the same. Also, I tried with JetPack 4.4 and Wifi works well (but I don’t want this version of CUDA and cuDNN).

FYI: I tried this wifi dongle in another Jetson Nano with L4T 32.1 and works well.

Please, help me to stablish the connection using wifi dongle.

I am wondering why ethernet wire does not respond.

Do you have a HDMI monitor connected on your board? Do you see anything on HDMI monitor?
Is this your first time flashing the board?

Yes, I have a HDMI monitor connected. This is not the fisrt time flashing the board. When I power on the Nano, on the first black window appears this messages:

Then, it boots normally and Ubuntu begins to work as normal it do.

Finally solved.

Who did I solved it? Installing the correct wifi driver. It’s a little bit hard without Internet. It’s necessary download dkms in a computer with Internet for Ubuntu 18.04 and aarch64. Copy the deb file to our Jetson Nano and installing it (“sudo apt-get install /route/to/dkms.deb/file”). Then install the wifi driver from this repo (downloaded in a computer with Internet and copied to Nano):

Hope this can help someone! :)