Ethernet connectivity issues - Kodi

Hi, I’m having trouble getting the ethernet connectivity stable. I used an old image (18.04) I already had in the jetson nano. The ethernet connectivity was not stable at all. I used a wifi usb adaptor and the ethernet RJ45 cable.
With the wifi after a couple of minutes I have to unconnect and reconnect (in ubuntu) to have the internet going.
And I have exactly the same problem wired.

So I thought that the image was bad ? I replaced it with this one Xubuntu 20.04 Focal Fossa L4T R32.3.1 - Custom Image for the Jetson Nano - Jetson & Embedded Systems / Jetson Nano - NVIDIA Developer Forums
Exactly the same problem so I guess it is hardware ?

I just want to try out Kodi on the Jetson Nano but add-ons and scraping aren’t updated because of that. And the hard drive disk when I access it shuts down the Jetson Nano

Hi @AnotherBeginner

I am moving this to the Jetson category for visibility.

Hi Tom, sorry about that the labeling got me confused, thanks

Hi,

Sorry to say that actually I have no idea about what your issue is. We only deal with the devkit board and jetpack image here.

If you are using some customization board or customization image, then we have no direct answer to your question. Better consulting with your board vendor first or the one who provided you the image.
For example, I totally have no idea about what is Kodi. It seems not related to ethernet connection.

If you still want to check your issue, maybe you can try to share the kernel log first.

Hi, I’m not using a custom board, I’m using Nvidia Jetson Nano DevKit here (fr)
I first didn’t use a custom image I used the 18.04 one (I had it in the Jetson Nano from when I used it a lot back in 2020). The internet connection was really poor, lots of blackout I had to disconnect/reconnect every 15 minutes. Exactly the same issues If I used RJ45 or USB wifi dongle.
Now with the Xubuntu image I have the same issues.
Sorry how can I share the kernel log, it’s been a while.

Hi,

Ok, please follow below instructions

  1. No matter what software you are using. Please just reflash your board with sdkmanager and choose jetpack4.6.2 to flash.

  2. After the board gets flashed and boot, please check if the issue is still.

Honestly, we don’t have other users reporting this. Also, my jetson nano is online for 24x7, if the network is really becoming dead in every 15 mins, then I won’t be able to remote access. However, this does not happen.

So please try to refresh your software version first. I feel you are using a very old BSP software…

If the issue still happened, after the issue happened, run “dmesg > log.txt” and attach the log here. It will have the kernel log.

Also, try to remove micro usb cable from your jetson and see if it enhances.

OK so I installed sdkmanager jetpack 4.6.2 (it asked to update itself to 5.0.2 I said no) on Ubuntu 18.04, I do get notified that my system doesn’t have the minimum 8go requirements but I can press for it to “reduce concurrent file download” so I guess it will be longer to download.
It says “no board connected”
I ran lsusb I don’t have nvidia Corp listed.
My os on jetson nano does work I can use it.
I use ethernet wired and I have 5V4A power brick. I also tried with my lab power supply 5V10A with 470uF.
Only thing I guess worth mentioning is that I have a fan plugged on top of the cooler.

Did you put your board into recovery mode?

Good catch I didn’t i followed another topic where you indicated the steps.
Now it is flashing the firmware i had a problem with my password it was “enter” but it’s not what i had set.
Anyway now i should have a good internet connection so i will try to use it has is and i will change the os back to xubuntu i guess. I keep you updated

Hi again installation completed internet works very well i even managed to install Kodi. All works well (it has a hard with more 1080p that’s what i wanted to try out) thanks a lot for your time