Connecting two jetson nano via ethernet and switch

Hi there,

For an application I need to make a TCP connection between two jetson nano via ethernet. I connected each jetson nano via ethernet interface using ethernet cable to a switch. However, when I run command


, I do not get any IP address for eth0, but only bridge l4tbr0 has an ip address

I tried to click on connections set as manual IP and on IPv4 page and set details as
IP :
subnet mask :
gateway :

on the other jetson, IP :

But when I do ping it says host unreachable

I have the following questions:

  • why when it is on dynamic DHCP, it does not show any ip address for eth0 when I run ``` $ifconfig ```
  • what is l4tbr0 connection? shall I change this connection?
  • how could I make the connection work correctly

Many thanks

First: When you connected the two Nanos to a switch, was that switch also connected to a DHCP server of some sort?

Second: For static IP address configuration, you need to make sure the network you’re using isn’t ambiguous. If the l4tbr0 device is using the 192.168.55.x/24 network, it’s probably a bad idea to use this exact network for the ethernet devices.

I believe the l4tbr0 bridge is the one that emulates a USB Ethernet adapter when the Nano is connected to a PC over USB.

Assuming the switch does not actually have a DHCP server on it, I’d suggest you set up a standard private network:

  1. On Nano A, set the IP address for Ethernet to and the netmask to
  2. On Nano B, set the IP address for Ethernet to and the netmask to

Now, if you check “route -a -n” you should be able to see addresses in the 10.0.0.x range being mapped to Ethernet.
At this point, you should be able to “ping” from the device, and it should work.

Hi snary, many thanks for your answer.
There was no DHCP server and I assigned the IP addresses as you suggested in range 10.0.0.x and it worked perfectly fine.