Jetson Nano Headless using Windows 10

Hi All,

I have recently brought Jetson Nano Kit and downloaded and flashed JetPack 4.5 image on the micro sd card. The device is powered using 5V/5A adapter with jumper correctly set. I have connected a micro usd cable and drive pops up in windows. There I found some readme and gone through it. I’ve then used cmd to ping 192.168.55.1 and got reply. So far so good. Then I used ssh nvidia@192.168.55.1 as told by Jetsonhack youtube video. But I got an error saying connection refused. Then I tried all possible username for ssh like nano, windows user name, admin etc and still the same connection refused error.

I even tried serial on the serial port using putty at 115200 but no success. The readme doesn’t say anything on username and password.

Can someone tell me, what is the default ssh username/password for the setup? How to setup this device if not by ssh or serial (I don’t have linux except through virtual machine, and I don’t have a display)?

Thanks!

I tried all baud rates and hardware control modes combination keeping 8N1 configuration as told in the Nvidia setup guide page now, nothing seems to bring setup screen. The ping still works for 192.168.55.1, so I don’t think there is a hardware problem.

I believe now that Nvidia is not upfront about their documentations on the possible issues on the setup page. If headless setup is not possible, then say in the documentation so than leaving the users’ time wasted in the futile efforts. If there are issues, notify about them. Update the user guides, on some Nvidia setup pages it is still from 2019. I’ve already tried 2 images (4.5 and 4.6) flashed as per instructed.

Sorry to say, but I find it unacceptable from Nvidia. I have configured many Raspberry Pi in headless mode in minutes and here I’m stuck with Jetson Nano that doesn’t connect, but ping perfectly.

I have disabled Windows 10 driver driver enforcement to install unsigned CDC NCM driver and also re-flashed the sd card again and it worked with putty. I could configure the system os and now can access it with ssh.

Glad to know it can work now.