Nvidia Jetson Nano 2gb cannot connect to pc via a USB

When I use to nano to my pc I could see nano in device manager under ports and it worked fine , but now I don’t have any idea why nano doesn’t recognize my laptop after connecting the usb . I checked it using a different laptop and it worked fine .

What does this mean? What’s the issue you met?

When I connect jetson nano to my laptop via usb my laptop recognizes it but if I remove and reconnect the usb cable then either nano doesn’t recognize my laptop or the other way around .
Does this clears it up a bit ?

can you please tell me what’s wrong I’m stuck and cannot work on my nano.

It does not clear up.
When does it recognize the each other? Sometimes it work and sometimes it not? How about changing a better quality of usb cable?

And is that laptop a ubuntu 16.04 / 18.04 desktop? We don’t validate the Windows host for jetson device mode.

Your topic is nearly same as this one. This interface depends on below items to make it work. So check those first.

No, Both of those laptops are windows.
It recognizes jetson nano when I restart the laptop again and again.
How can I check where the problem is other than changing the cable (I’ll try that but it works in alternate laptop se we can sule that out).