Internet connection to Jetson Xavier

Hey, I can’t connect the jetson Xavier to the internet using ethernet connection to the router since i don’t have that kind of connection to the home router. Are there other ways i can connect the jetson to the internet? maybe using wi-fi or ethernet connection to the PC?


Hi giltech,

What’s your JetPack version?

You could use TypeC-USB (the port which you flash the board) for Tethering if your host PC could access internet.
Or you can connect ethernet from your host PC and configure for network sharing feature depending on your host OS.

You might need the following command to check current stauts:
$ ifconfig → check available network interface
$ systemctl status nv-l4t-usb-device-mode → check USB device mode service


My host PC is Windows and I’m running ubuntu 18.04 Virtual machine.
In the SDK manager the “Target Operating System” is JetPack4.6.3.

I tried to connect the TypeC-USB to the VM and the host PC (Windows) but i got an error that connection is failed.

I ran the commands you mentioned in the Jetson Xavier. The result for systemctl status nv-l4t-usb-device-mode is:

How should I continue from here? Thanks.

I would suggest using standalone Ubuntu host PC because VM is not supported for SDKManager to flash the board.

Where do you see the connection failed?

You could run ifconfig on the board first to check the network interface available to be used.

Unfortunately, i don’t have the option to use standalone ubuntu. Although, i succeeded to flash the board using the SDKManager from the VM.

The connection failed error has been received in the Jetson and the VM simultaneously.

Result of ifconfig:

Result of systemctl status nv-l4t-usb-device-mode:

The connection between Jetson and VM would be unstable because your USB is connected on Windows host and switch to VM (Ubuntu) manually.

Your result of ifconifg showed several network interfaces could be used.
Do you try to ping your board from host PC succesffuly?
And then set up bridge for network sharing from your host PC.

Ping command wasn’t successful from host PC (Windows and Linux VM).
I tried to ping the usb0 network interface in the Jetson while usb TypeC cable was connected between the Jetson and PC.

You should ping ip of l4tbr0 interface which is created through nv-l4t-usb-device-mode service.

ping for l4tbr0 interface was successful, but still no internet connection.

If you could ping l4tbr0 successful, it means the connection from the board to your host PC is established.
You just need to create network sharing on this interface from your host PC. This feature might depend on you host PC OS.

My host PC is Windows 10 Home and I also installed on it VM Linux 18.04 (ping to l4tbr0 worked from both platforms).
Is there a recommendation from which platform to create the network sharing? (Windows/Linux VM).
I would appreciate useful guide/reference for how to create that network sharing.

Thank you very much!

For Windows10, I found the steps and verified it could enable network sharing
Internet Connection Sharing in Windows 10 - Microsoft Community

From drop-down menu, just select the RNDIS network interface of your device.
And you might need to set IP address automatically:
Ethernet X → Right Click → Properties → TCP/IPv4 → General → Obtain an IP address automatically

It worked!
Thank you so much!!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.