IOstat illegal specifier error

open (unit=11, file=’/toon/kwilson/Programming/NetBeansProjects/FortranFiles/ObjectAsciiFiles/’ // datefilename, &
& form=‘formatted’, access=‘sequential’, action=‘read’, iostat=filestatus, position=‘rewind’, status=‘old’)

/usr/bin/make -f nbproject/Makefile-Default.mk SUBPROJECTS= .build-conf
make[1]: Entering directory /toon/kwilson/Programming/NetBeansProjects/FortranFiles/ObjectAsciiFiles/ObjectAsciiFiles' cd /toon/kwilson/Programming/NetBeansProjects/FortranFiles/ObjectAsciiFiles && /usr/bin/make -f Makefile make[2]: Entering directory /toon/kwilson/Programming/NetBeansProjects/FortranFiles/ObjectAsciiFiles’
pgf90 -g -O0 -c StatsObsDat.f90

PGF90-S-0201-Illegal I/O specifier - IOSTAT (StatsObsDat.f90: 101)

PGF90-S-0038-Symbol, filestatus, has not been explicitly declared (StatsObsDat.f90)
0 inform, 0 warnings, 2 severes, 0 fatal for statsobsdat
make[2]: *** [StatsObsDat] Error 2
make[2]: Leaving directory /toon/kwilson/Programming/NetBeansProjects/FortranFiles/ObjectAsciiFiles' make[1]: *** [.build-conf] Error 2 make[1]: Leaving directory /toon/kwilson/Programming/NetBeansProjects/FortranFiles/ObjectAsciiFiles/ObjectAsciiFiles’
make: *** [.build-impl] Error 2
BUILD FAILED (exit value 2, total time: 78ms)

sorry but I don’t get this error as the adams,brained, martin,… say’s I can use this option!

Hi kevomac12,

You need to declare ‘filestatus’ as an integer.

Hope this helps,
Mat