Issue of NTP

Hi:
Recently I would like to give the GPS time to Jetson Nano via NTP, I followed the instruction in: Adding a PPS source to ntpd | Steve's Blog, but when I finished the instruction, I could not get the ntp from GPS time, I will appreciate if you can give me some advice to solve this problem. When I used the command: sudo service ntp status, the result is :


The time is not the GMT time.
My ntp.conf file is:

/etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

Leap seconds definition provided by tzdata

leapfile /usr/share/zoneinfo/leapseconds
logfile /var/log/ntpd.log

Enable writing of statistics records.

#statistics loopstats peerstats clockstats
#filegen loopstats file loopstats type day enable
#filegen peerstats file peerstats type day enable
#filegen clockstats file clockstats type day enable

ACL, Access Control Commands and Options

restrict -4 default notrap nomodify nopeer noquery limited
restrict -6 default notrap nomodify nopeer noquery limited

Needed for adding pool entries

restrict source nomodify noquery notrap
restrict 10.1.1.0 mask 255.255.255.0 nomodify
restrict 127.0.0.1
disable monitor

upstream ntp server list

pool time.apple.com iburst

ntp driver 28(SHM), Shared Memory Driver

GPS time

#server 127.127.28.0 minpoll 4 maxpoll 4
#fudge 127.127.28.0 time1 +0.46 refid GPS

Accurate PPS time

#server 127.127.28.1 minpoll 4 maxpoll 4 prefer
#fudge 127.127.28.1 refid PPS

ntp driver 20(GPS_NMEA), Generic NMEA GPS Receiver

server 127.127.20.0 mode 17 minpoll 4 maxpoll 4 prefer
fudge 127.127.20.0 time2 0.46 flag1 1 flag3 1 refid GPS

Hi, I feel that the Compute Sanitizer forum is the wrong place for this. Moving to the Jetson Nano forum for better visibility.

Maybe check with Steve for the /usr/share/zoneinfo/leapseconds sys node.