Issue with SPI1

I am trying to use the SPI Bus on the Devkit but am not able to get it working. I followed the steps here:
https://devtalk.nvidia.com/default/topic/1044595/jetson-agx-xavier/question-how-do-i-enable-and-address-spi-ports-/post/5307630/#5307630

The spidev module is loaded and I tried to send bytes via the python spidev library but I am not seeing any activity on the clk line using my oscilloscope.

Any ideas?

python code:
import spidev
spi = spidev.SpiDev()
spi.open(0, 0)
to_send = [0x01, 0x02, 0x03]
spi.xfer(to_send)

Could you try spidev_test utility.

Hi pnewmanCTI,

Any update? Is this still an issue on you end?

Thanks

I have same question.

The SPI1 is spidev0.0?

I modify the dts like below.

spi@xxxxxx {
    ...
    status = "okay"; // Before change: "disable"
    spidev@0 {
        compatible = "spidev";
        reg = <0>;
        spi-max-frequency=<25000000>;
    };
}

Should I modify the pinmux value??

We are still having this issue. I haven’t tried the new Jetpack yet though.

Have a reference to below link to check the pinmux.

https://devtalk.nvidia.com/default/topic/1049170

I have my pinmux correct according to that thread but I am still not seeing anything on the clock or data lines…