Issues with nvidia-drivers in Ubuntu 22.04 and RTX4090

nvidia-bug-report.log.gz (126.7 KB)


I have a desktop computer with Intel i9-13900 processor, ASUS Prime Z790-P Wifi motherboard and a NVIDIA GPU ZOTAC RTX 4090 TRINITY with UBUNTU 22.04 LTS as OS for using as a Deep Learning Computer.

After several tries with driver 525 (my last attempt was with 525.105.17), there is an issue between the driver and Ubuntu Kernel (kernel is 5.19.0-40 generic) that makes impossible to the system complete the driver installation (installation breaks before completing)

I tried with the drivers in Ubuntu Software Updates and the official one in Nvidia Drivers Download page ,without any success.

I include in this message the .gz file obtained from running in the terminal.

I would be very pleased if you could help me to solve the issue or give me some recommendations for completing the proper driver installation.

Thanks in advance

The compiler is segfaulting and the kernel headers seem to be severely broken. There’s something really broken with your system, maybe check your system memory and reinstall.

I have made some memory checks and everything is working properly inside the memory.
It seems anything related with a problem between the linux kernel and the driver, so I have installed a fresh Ububtu 20.04 LTS version (kernel 5.15.0-71-generic) and try to install the driver 525.105.17 without any success and an error message in terminal (attached you can find a screenshot of it)

As you see in the screenshot, the resolution of the screen is low (I cant change it because of the problems with the driver), taking in account that I am using a 27" screen.
Thanks for your help!

I also tried with the new driver released yesterday (525.116.03) without success.

The file mentioned in the screenshot is attached to this message.

Thanks a lot!

nvidia-installer.log (3.2 KB)

This installer log also shows crashes, although it doesn’t say what exactly is crashing. Does coredumpctl list anything relevant? Can you run gcc in a console without it crashing?

You might need to apt install systemd-coredump and then try the install again in order for it to collect crash dump information.

I cant execute coredumpctl: when I try to run apt install systemd-coredump in terminal I have this message:

, then I run sudo dpkg --configure -a in terminal and system stop in the line Building initial module for 5.15.0-71generic and then gets freezed (all gets stopped in the screen and mouse doesnt react to movements).

This is something that happens for all versions of Ubuntu 20 and 22 and their respective kernels when I install the Nvidia driver (I have tried with 525.105.17, 525.89.02, 525.85.05, 525.78.01, 525.60.11 and 525.53).

Regarding the gcc, I can run it in a terminal:

Thank you for your help!

encounter the exact same issue, any progress here? how to resolve? thanks.

I have the same issue with 525 and 535, are there any solutions?

Downloading the run file didn’t help, GUI installation doesn’t work and the Terminal installation also doesn’t work.

They all get hung up on building systems and then fail.

I’m also having tons of issues trying to get drivers working for my 4090 on Ubuntu 22.04.