Issues with trying FD CAN loopback on Orin

Hello everyone,
I was trying to run FD CAN on the Jetson Orin. Using the WaveShare SN65HVD230 CAN transceiver. However, it didn’t work right away.
In the meantime, I am trying to debug the problem. In my initial tests. I tried the loopback test as suggested in the CANDeveloperGuide page. I have my Tx and Rx shorted for the loopback test. While ’ sudo cansend can0 123#abcd1235 ’ worked. I was also trying to send FD CAN by sending ’ sudo cansend can0 123##1abcd1235 '. But it gave me the following error : ‘CAN interface is not CAN FD capable - sorry.’

If anyone knows why this error showed up? To my understanding the Jetson Orin can work with FD CAN.
Thank you for your help.

Hi misbahlabs,

Are you using the devkit or custom board for AGX Orin?
What’s your Jetpack version in use?

The loopback test from developer guide is “internal” loopback test. It means you don’t need to connect any cable for CAN-TX and CAN-RX.

Do you add fd on as parameter when you setup the can interface?

$ ip link set can0 up type can bitrate 500000 dbitrate 1000000 berr-reporting on fd on

This transceiver is not CAN FD capable. You need something like MCP2558FD or TCAN1057AEV-Q1 or any other CAN-FD transceiver with separate Vio supply and CAN-FD capability.

And you need to connect CAN-H, CAN-L and GND. Not connecting GND leads to reliability issues.


Thank you everyone for getting back. While all of them are important points.
In my case, I found out that the address values I was setting through the terminal given hereJetson Platform Details were different to how it was setup using this step : Configuring the Jetson Expansion Headers (which solved my problem)