Issues with Ubuntu not recognizing 3060 laptop

Hi! I’m a newcomer of machine learning and ai. Recently encountered a problem which is with my new laptop(with dual graphical cards, one inboard amd and an independent 3060)that has been rooted as Ubuntu 22.04 LTS.
Primarily, I hoped to implement the cuda GPU accelerator for pytorch and tensorflow,so I tried to install the drive of 535.11, so that I’ll be able to install CUDA. however, it shows that " You do not appear to have an NVIDIA GPU supported by the XXX NVIDIA"
I then turned to the setting, seeing there shows Graphic : RENOIR(renoir,LLVM and etc.)
So again I tried lspci | grep VGA command and found only the amd GPU
Thus here I am, with nothing to do , if any help, Thank You in advance

Plus ,also tried to modify the grub to disable the amd GPU using ’GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash radeon.modeset=0”‘ , but it didnt seem to help at any bit

Guys!!! Issue solved with rebooting with Ubuntu 20.04 LTS. I do like the 22.04 UI though