How to install Nvidia GPU on ubuntu

I used to be such a huge fan of Ubuntu until I installed 13.10 Saucy Salamander. It lags so much its not even funny. I think this is due to the fact my Nvidia GPU aint being picked up Ive been to the additional drivers tab countless of times but I KEEP GETTING A BLANK LIST with the message no proprietary drivers found. Please help because I do not like windows as much as I do Ubuntu but i cant use it if it lags so much. And Ive tried the “sudo get update nvidia current” but that gifts me with a blank screen…what can I do?


Heres what happens when I run “lspci -nnk | grep -iA3 vga”

championsonline@ubuntu:~$ lspci -nnk | grep -iA3 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller [8086:a001] (rev 02)
Subsystem: Lenovo Device [17aa:3607]
Kernel driver in use: i915
00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 02)

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218M [GeForce 305M] [10de:0a73] (rev a2)
Subsystem: Lenovo Device [17aa:3607]
Kernel driver in use: nouveau
03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

My unity support test results

championsonline@ubuntu:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string: 2.1 Mesa 10.2.0-devel

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: no

I am assuming that this is a laptop with Optimus… if so, you need to use either bumblebee – http://bumblebee-project.org/ or one of the latest drivers configured correctly with xrandr support – something like this, perhaps: http://zeronteproject.com/74/

I have no idea what Optimus is? Also it’s a all in one desktop so idk if that qualifies as a laptop?