[URGENT] Nvidia seriously giving me grief on ubuntu linux

Ubuntu not picking up my Nvidia driver on the additional drivers tab. As a result my desktop is freezing like hell because its using llvmpipe as the graphics provider.

I used to be such a huge fan of Ubuntu until I installed 13.10 Saucy Salamander. It lags so much its not even funny. I think this is due to the fact my Nvidia GPU aint being picked up Ive been to the additional drivers tab countless of times but I KEEP GETTING A BLANK LIST with the message no proprietary drivers found. Please help because I do not like windows as much as I do Ubuntu but i cant use it if it lags so much. And Ive tried the “sudo get update nvidia current” but that gifts me with a blank screen…what can I do?


Heres what happens when I run "lspci -nnk | grep -iA3 vga"

championsonline@ubuntu:~$ lspci -nnk | grep -iA3 vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller [8086:a001] (rev 02)
Subsystem: Lenovo Device [17aa:3607]
Kernel driver in use: i915
00:1b.0 Audio device [0403]: Intel Corporation NM10/ICH7 Family High Definition Audio Controller [8086:27d8] (rev 02)

02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GT218M [GeForce 305M] [10de:0a73] (rev a2)
Subsystem: Lenovo Device [17aa:3607]
Kernel driver in use: nouveau
03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

My unity support test results

championsonline@ubuntu:~$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string: 2.1 Mesa 10.2.0-devel

Not software rendered: no
Not blacklisted: yes
GLX fbconfig: yes
GLX texture from pixmap: yes
GL npot or rect textures: yes
GL vertex program: yes
GL fragment program: yes
GL vertex buffer object: yes
GL framebuffer object: yes
GL version is 1.4+: yes

Unity 3D supported: no

How can I change my kernel from noveau to nvidia???

I don’t intend to be snarky, but I used to use Ubuntu too but it kept having issues so I switched to Manjaro Box (Arch based). And it all works great. If you have used linux for a while you will probably really like Manjaro. The NVIDIA drivers work out of the box. And using yaourt it was easy to get CUDA installed as well.

To also give some help with Ubuntu: see https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia

According to my previous post is is my GPU a 304M or GT218M?