Jax profiling libcupti.so error

cross-referencing from discourse

Hello when I try to run jax profiling in container (jax:23.01-py3) I get

Could not load dynamic library ‘libcupti.so.11.8’; dlerror: libcupti.so.11.8: cannot open shared object file: No such file or directory; LD_LIBRARY_PATH: /usr/local/cuda/extras/CUPTI/lib64:/usr/local/cuda/compat/lib:/usr/local/nvidia/lib:/usr/local/nvidia/lib64

I tried to add to the docker file
ENV LD_LIBRARY_PATH=/usr/local/cuda-11.8/lib64:$LD_LIBRARY_PATH

But no luck generally I can not find libcupti.so.11.8 anywhere - what could be done?

I had also seen if I am not mistaken that there is both CUDA 11.8 and CUDA 12 in usr/local - can it be the source of the problem

in /usr/local/cuda-12.0/lib64 I had found libcupti.so; libcupti.so.12 and libcupti.so.2022.4.1 but those do not satisfy requirements of the profiler

In my case adding to dockerfile

ENV LD_LIBRARY_PATH=/usr/local/cuda-12.0/NsightSystems-cli-2022.5.1/target-linux-x64:$LD_LIBRARY_PATH

solved the problem

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.