problem running computeprof with Cuda 4.0 and Centos 5.5

Dear Forum

I recently installed Cuda Toolkit 4.0 in the standard place, the sdk and
the examples. There was one installation problem, the usual problem with
the nouveau driver which must be blacklisted before X will run again.

But that solved, I have compiled examples, compiled my own programs, etc.

The one thing that does not work which I could use right now, is computeprof,
which I think is what we call the profiler these days.

It complains: “computeprof: symbol lookup error: computeprof: undefined symbol:

My LD_LIBRARY_PATH has /usr/local/cuda/lib64 and /usr/local/cuda/bin and

Has anyone else experienced this ? Does anyone have any suggestions ?

Thank you,

The problem was that I also had Qt4 installed in another directory,
and had a reference to that directory in my LD_LIBRARY_PATH. When
I removed that reference, computeprof used the qt4 libraries in
/usr/local/cuda/computeprof/bin and everything worked. Or at least,
everything worked so far.


I had the same problem, but when I add a similar directory of your /usr/local/cuda/computeprof/bin to LD_LIBRARY_PATH, it started to work.
My environment variables have the following two relative to this:

Path has these:

LD_LIBRARY_PATH has these: