Visual Profiler : Unable to Load CUDA Library Visual Profiler error in Ubuntu


I get this error dialog box when i try to run cudaprof

I am using Ubuntu with CUDA. I have a Tesla Machine with a cuda setup that is running perfectly.

I have seen a couple of other threads with the same issue, but I could not find a solution to resolve it. We have huge programs (about 5000 lines of code) in cuda and we really need to profile them asap. Any help would be highly appreciated.


PS:- I dont know whether this adds any extra information - but the machine is 64 bit.


For the profiler to work, it has to be able to fork and run your code. You need to make sure that all the paths to the dynamically loaded libraries your executable needs are known to the link loader, either via the shared library cache, or the LD_LIBRARY_PATH environment variable. Otherwise the profiler fork will fail, which sounds like what is happening in this case.

For what it is worth, I have 64 bit Ubuntu 8.04LTS and 8.10 systems running the V2.1 and V2.2 profiler without problems.


Thanks for your reply. I export the LD_LIBRARY_PATH environment variable every time before I run cudaprof. So my paths are fine. Infact, had my paths been incorrect, I would have got an error like - “could not load shared libraries” etc.

Infact, once I get that error dialog box saying - Unable to load the ‘cuda’ library. CUDA Visual Profiler device features will be disabled" I click 'OK" and get to see the visual profiler window.

But the buttons and menu bars are inactive. And I can only view the existing profiled files in .cpj format. i cannot open/create new projects. In essence, my paths are okay. There is something else that is going wrong.

But it’s good to hear that you have the profiler working on your 64bit machine.

Please help.


what versions of everything are you running?

Operating System - Ubuntu 8.10, 64bit

CUDA Toolkit and SDK 2.2, 64bit

Cuda Visual Profiler - Latest one downloaded from CUDAZone. (I have tried for version 1.1 and another version that was for download on this very forum)



You probably should be running the version supplied in the toolkit. What NVIDIA driver version are you using?

Version supplied in the toolkit??

The linux toolkit compatible with Ubuntu is a .run file. What is the default path of the version of Visual Profiler supplied with the toolkit??

In my copy of the 2.2 toolkit, it is in /your_install_prefix/cuda/cudaprof/bin

I will ask again about the CUDA driver, because libcuda (which is what apparently is the problem) is supplied in the driver package, rather than the toolkit.

The version of Nvidia drivers I’m using is - 185.18.08 Beta

I’ve tried pretty much everything, and still can’t get my profiler to work… Any more ideas? Please help!

I encountered the same problem when using the x86_64-185.18.10 driver.
Switching to x86_64-185.18.14 solved the problem for me.


That’s actually key… I had the same problem on my 64-bit Ubuntu 8.04 box running CUDA 2.2 (Driver 185.18.14). I found the fix in this post:

During the driver install you want to have it install the OpenGL 32-bit compatibility drivers. Apparently, cudaprof needs them. I had explicitly not installed them because A ) I wasn’t doing any OpenGL stuff and B ) I didn’t think I was running any 32-bit code.

Hope that helps.