Jetbot camera not working on jupyter notebook

i was trying to run this code on my jetbot from the jupyter noteboook road following
from IPython.display import display
import ipywidgets
import traitlets
from jetbot import Camera, bgr8_to_jpeg

camera = Camera().instance(width=224, height=224)

image_widget = ipywidgets.Image()

traitlets.dlink((camera, ‘value’), (image_widget, ‘value’), transform=bgr8_to_jpeg)


but it keeps running and stops with out returning any output? and i am using chrome browser can anyone help me please

You can check if the camera is good by running:

gst-launch-1.0 nvarguscamerasrc ! fakesink

If above command works, can try to save to a file and check if the video frames are good:

gst-launch-1.0 nvarguscamerasrc num-buffers=150 ! nvv4l2h264enc ! h264parse ! matroskamux ! filesink location=a.mkv

The suggested cameras are listed in
Bill of Materials - JetBot

so i wasnt sure where to run the command so i tried it for both the python notebook and terminal
when i ran the command : gst-launch-1.0 nvarguscamerasrc ! fakesin
in the notebook it says invalid syntax error
and when i ran it in terminal it returns: WARNING: erroneous pipeline: no element “fakesin”

now when i run the camera command i wrote in my first question it returns the following error:
Server Connection Error
A connection to the Jupyter server could not be established. JupyterLab will continue trying to reconnect. Check your network connection or Jupyter server configuration.


WARNING: erroneous pipeline: no element “fakesin”

It seems like there’s a typo. It should be fakesink. Please open a terminal and try the commands.

so when i ran the command : gst-launch-1.0 nvarguscamerasrc ! fakesink
i get the following output, does this mean its working?:

The camera is running. The hardware setting should be good. Can you re-flash and follow the guidance step by step?
Using SD Card Image - JetBot

See if reinstallation helps.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.