JetPack 4.4 - L4T R32.4.3 issue with darknet yolo

I am trying to compile darknet with https://github.com/AlexeyAB/darknet

GPU=1
CUDNN=1
CUDNN_HALF=0
OPENCV=1
AVX=0
OPENMP=0
LIBSO=0
ZED_CAMERA=0
ZED_CAMERA_v2_8=0

When I try to make -j4

./src/convolutional_layer.c: In function ‘cudnn_convolutional_setup’:
./src/convolutional_layer.c:286:24: error: ‘CUDNN_CONVOLUTION_FWD_PREFER_FASTEST’ undeclared (first use in this function); did you mean ‘CUDNN_CONVOLUTION_BWD_FILTER_ALGO_3’?
int forward_algo = CUDNN_CONVOLUTION_FWD_PREFER_FASTEST;
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
CUDNN_CONVOLUTION_BWD_FILTER_ALGO_3
compilation terminated due to -Wfatal-errors.
Makefile:164: recipe for target ‘obj/convolutional_layer.o’ failed
make: *** [obj/convolutional_layer.o] Error 1

My JP 4.4 GA was upgrade from JP 4.4 DP

Hi @samsonli,
Moving this to Jetson Team so that the team can help you better.
Thanks!

Hi,

There are some API update in our new cuDNN package.
Please check this document for the details.
https://docs.nvidia.com/deeplearning/sdk/cudnn-api/index.html#release-800-preview

We are also trying to provide a patch for darknet.
Will update the information with you once the patch is ready.

Thanks.

Hi,

The patch for darknet + cuDNN v8 is available.
Please check this comment for the detail information:


Thanks.

1 Like

Hi @AastaLLL,
I tried to apply patch with git am

jetsonnano@jetson:~/darknet$ git am 0001-fix-for-cudnn_v8.patch
fatal: previous rebase directory .git/rebase-apply still exists but mbox given.
jetsonnano@jetson:~/darknet$ git apply 0001-fix-for-cudnn_v8.patch
error: patch failed: src/convolutional_layer.c:145
error: src/convolutional_layer.c: patch does not apply
jetsonnano@jetson:~/darknet$

the source to convolutional_layer.c

were there any i missed?

Thx

Hi,

It looks like there is other patch applied in your source.

fatal: previous rebase directory .git/rebase-apply still exists but mbox given

The patch can be used on the top of official darknet source.
By the way, please noticed that there is a updated version to limited the memory usage for Jetson device.

$ git am 0001-fix-for-cudnn_v8-limited-memory-to-default-darknet-s.patch

Thanks.

Hi, Samsonli

Here is the detail steps for darknet on JetPack4.4GA for your reference:

Thanks.