JetPack 4.6 Xavier NX how do I modify the correct PIbMUx with Excel

I tried to modify the EXCEL file of NX and generate the correct CFG file through puthon,
but I don’t know how to correct the modification,
may I ask if there is a sample for reference?
For example, I want to enable Uart0 and CAN0 so that GPIO can run correctly

Why not just change it through pinmux spreadsheet? I don’t get your question here.

Do you want to know how to use this excel file?

yes ,i do not know how to use excel file ,

So you want to change UART0 and CAN0 to gpio pin?

No, I’m not sure how to use a spreadsheet.


As shown in the screenshot, I have modified the usage configuration of uart0, but the resulting pinmux.dtsi is unchanged by comparison.

Another question is, I don’t know where the generated CFG is placed to take effect.

图片

I tried to modify the file directly, as shown in the screenshot, but when I performed the Flash write, it was changed back to its original value,
JetPack_4.6_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra/bootloader/tegra19x-mb1-pinmux-p3668-a01.cfg

So I want to know a correct, complete way to modify Pinmux

Hi,

Those files under /bootloader are actually just “copies” of the real file from bootloader/t186ref/BCT.

Thus, you need to modify the real file instead of those copies.

Thank you for your answer. I immediately tried.
But it didn’t solve my problem

I have tried, changing directory files bootloader/t186ref/BCT is not valid, register values of files in this directory will also be changed to default values

I still don’t understand the question

What is your method to flash the board…?

sudo ./flash.sh jetson-xavier-nx-devkit-emmc mmcblk0p1

What did you change inside this cfg file? And how do you know this change does not take effect?

I modified the CFG file ,pimmux.0x0c303020 = 0x00000458
After flash writes, the instruction obtains the modified register value :busybox devmem 0x0c303020

Could you pick up some other pins and see if your change will take effect?

For example, pick one pin that you are sure it is not in use, configure it, flash it and read the register again.

Also, did you remember to delete the old copies before flashing the new one?

i have modified all cfg file

Hi Wayne:
they want kown the detail steps for use the Pinmux modify the GPIO, do we have this guide?

I think what he did is already correct.

If you don’t believe that cfg file is getting flashed to the board, then you can make an experiment. Move the cfg files to somewhere else as a backup and let flash.sh not able to find it.

Flash the board and see if flash.sh will give out any error. If it will, then it means this file is needed. Otherwise it means you modify the wrong file.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.