Jetpack 5.0.2,Jetson AGX Orin Developer Kit, one type-c not working

here is the eeprom dump. the orin module is on the Jetson AgX Orin developer kit

another information is that I have modify the tegra234-mb2-bct-common.dtsi.

sed -i “s/cvb_eeprom_read_size = <0x100>;/cvb_eeprom_read_size = <0x0>;/g”

so it is because I change the read size???


I am not sure why you want to disable read size on “devkit”. You shouldn’t do that on devkit. That will affect the functionality. I mean you may get some other functionality problem on devkit if you did that. Even something not related to this usb C port issue may happen.

Hi All,

Please try the solution here instead of the remvoing dtbo solution mentioned in previous comment.

--- p3701.conf.common_ori       2022-09-02 01:40:41.250541164 +0800
+++ p3701.conf.common   2022-09-02 01:40:55.714453715 +0800
@@ -69,7 +69,7 @@

        # p3701-0000
        if [ "${chip_sku}" = "00" -o "${chip_sku}" = "D0" ] &&
-          [ "${board_FAB}" = "400" -o "${board_FAB}" = "TS4" -o "${board_FAB}" = "RC1" ]; then
+          [ "${board_FAB}" = "500" -o "${board_FAB}" = "400" -o "${board_FAB}" = "TS4" -o "${board_FAB}" = "RC1" ]; then
1 Like

well, because we have a custom carrier board, the orin module will monut on the custom board.

I will try the solution you mention above.


The new fix – adding ${board_FAB) = “500” to the if statement – also corrects the USB-C and MGBe problem for us with the standard devkit. Thank you!

1 Like

Tried with the new method, but didn’t work for me.

not work too.

Hi @luciferydy @wangliyong

What are the flash command you two using to flash the board?

The actual patch that will be added in next release would be like this.

diff --git a/scripts/board_config/p3701.conf.common b/scripts/board_config/p3701.conf.common
index 104cc59..3ed55d3 100644
--- a/scripts/board_config/p3701.conf.common
+++ b/scripts/board_config/p3701.conf.common
@@ -59,26 +59,13 @@
 	if [[ "${chip_sku}" =~ ":" ]]; then
-		chip_sku=`echo "${chip_sku}" | awk -F ":" '{print $4}'`;
+		chip_SKU=`echo "${chip_sku}" | awk -F ":" '{print $4}'`;
 	# do not override BPFFILE for INT SKU "00"
-	if [ "${chip_sku}" != "00" ]; then
-		BPFFILE=`echo "${BPFFILE}" | sed "s|T.*-A1|${bpmp_fw_binary[${chip_sku}]}|"`;
+	if [ "${chip_SKU}" != "00" ]; then
+		BPFFILE=`echo "${BPFFILE}" | sed "s|T.*-A1|${bpmp_fw_binary[${chip_SKU}]}|"`;
-	# p3701-0000
-	if [ "${chip_sku}" = "00" -o "${chip_sku}" = "D0" ] &&
-	   [ "${board_FAB}" = "400" -o "${board_FAB}" = "TS4" -o "${board_FAB}" = "RC1" ]; then
-		PINMUX_CONFIG="tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi";
-		PMC_CONFIG="tegra234-mb1-bct-padvoltage-p3701-0000-a04.dtsi";
-	fi
-	# p3701-0004
-	if [ "${chip_sku}" = "D2" ]; then
-		PINMUX_CONFIG="tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi";
-		PMC_CONFIG="tegra234-mb1-bct-padvoltage-p3701-0000-a04.dtsi";
-	fi
 # Process_board_version:
@@ -222,9 +209,9 @@


diff --git a/scripts/board_config/p3737-0000+p3701-0000.conf b/scripts/board_config/p3737-0000+p3701-0000.conf
index 1c6b52e..80222d8 100644
--- a/scripts/board_config/p3737-0000+p3701-0000.conf
+++ b/scripts/board_config/p3737-0000+p3701-0000.conf
@@ -63,6 +63,13 @@
+	# update pinmux for concord
+	if [ "${chip_SKU}" = "00" -o "${chip_SKU}" = "D0" ] &&
+	   [ "${board_FAB}" = "TS1" -o "${board_FAB}" = "TS2" -o "${board_FAB}" = "TS3" -o "${board_FAB}" = "EB1" -o "${board_FAB}" = "EB2" -o "${board_FAB}" = "EB3" -o "${board_FAB}" = "000" -o "${board_FAB}" = "100" -o "${board_FAB}" = "200" ]; then
+		PINMUX_CONFIG="tegra234-mb1-bct-pinmux-p3701-0000.dtsi";
+		PMC_CONFIG="tegra234-mb1-bct-padvoltage-p3701-0000.dtsi";
+	fi

In brief, the usb C issue here is due to the pinmux file is wrong. Thus, need to correct them to the a04 one.

sudo ./ jetson-agx-orin-devkit mmcblk0p1

Used this command.
And created default user using the bash file under tools directory.

I can try the patch later.

if the correct pinmux file is a04 one, how the custom board with the pinmux dtsi files generated by pinmux excel do.

overwrite the a04 pinmux file, will the type c config will also be overwrite?


The actual point is… custom board may not have same usb type C design as devkit… so there is no consideration about this with default pinmux…

I ran into the same issue, and is still not working

well, you are right.

unfortunately, for our case, we use the flash typec port as the only usb port…

so I need a better understand of the typec use…

For anyone who still cannot have a successful result, please make sure

  1. You are really using jetpack5.0.2.

  2. You are really using NV devkit, but not some custom boards. This issue is only related to devkit.

  3. Please check if your board has the same board info as this. Only 3737-0000-400 board would be affected.

  1. Based on (2), if your carrier board sku/id is 3737-0000-400, then please go back to, check the log printed on the host and see if it is tegra234-mb1-bct-pinmux-p3701-0000-a04.dtsi in use.

If it is not this dtsi got flashed, please make sure you added the patch correctly.

If you are sure the patch is added correctly but the log still says the other pinmux dtsi is in use, then please also dump the eeprom on the module.

Command to dump module eeprom

sudo i2cdump -y 0 0x50

Command to dump carrier board eeprom

sudo i2cdump -y 0 0x56

1 Like

Followed this patch and flashed, but still not work. Below is the changed file and log.
flash.log (64.3 KB)
p3701.conf.common (7.7 KB)
p3737-0000+p3701-0000.conf (3.9 KB)

Then the i2cdump shows:

Btw I only have an intel based mbp nearby, the ubuntu system is directly installed on the hard drive.
I have tried flash simply remove tegra234-p3737-a04-overlay.dtbo using this mbp, the type-c port can work.

Also find the 699-13737-0000-400 H tag on my devkit.

Hi @luciferydy

Your jetpack is not jetpack5.0.2…

Aha, so embarrassed…

I was using workstation days before but forgot to update after back to mbp.
My bad, thanks for the help.
I will try 5.0.2 now…

How can I apply this patch if I install Jetpack via pip instead of flashing with a host?
And, can the development board use the micro USB for non-device mode? Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.