Jetpack 5.0.2,Jetson AGX Orin Developer Kit, one type-c not working

I use the Jetson AgX Orin developer kit. After upgrading from version 5.0.1 to 5.0.2, the type-C port near 40pin cannot work.

After inserting the hub, lsusb can see some information. However, after connecting to serial port devices, USB devices, or network devices, they can not be recognized.

In another case, the IP address of does not appear after connecting the computer.

The other type-C is ok.

In addition, in version 5.0.1, both type-C are work fine.

***@ubuntu:~$ lsusb
Bus 002 Device 003: ID 2109:0815 VIA Labs, Inc.
Bus 002 Device 002: ID 0bda:0420 Realtek Semiconductor Corp. 4-Port USB 3.0 Hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 006: ID 093a:2510 Pixart Imaging, Inc. Optical Mouse
Bus 001 Device 005: ID 04d9:1603 Holtek Semiconductor, Inc. Keyboard
Bus 001 Device 004: ID 2109:2815 VIA Labs, Inc.
Bus 001 Device 003: ID 0bda:5420 Realtek Semiconductor Corp. 4-Port USB 2.0 Hub
Bus 001 Device 002: ID 13d3:3549 IMC Networks Bluetooth Radio
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

My usb hub like this.

1 Like

We will set up and try to reproduce the issue. IS it specific to connecting to the hub? Or you try other hub and it also does not work?

Thank you for replay.

I tryed another type of hub, it cannot work too.

Hi there, I found similar issue with my Jetson AGX Orin Developer Kit after flashing 5.0.2 by

When connect to host comupter through the type-C port near 40-pin (the flash port), no usb device shows up on the host computer, and “dmesg --follow” shows nothing.
Below is the boot log from the microUSB port on the kit, hope it may help.

Log on microUSB Debug Port.txt (87.5 KB)

I have a similar problem on Orin without any hub. I used USB-C to access console. It worked fine in JP-5.0.1. Stopped working after the upgrade to JP-5.0.2. Flashed fresh JP-5.0.2 - not working.

With JP-5.0.1 host shows:

$ lsusb
Bus 003 Device 015: ID 0955:7020 NVIDIA Corp. L4T (Linux for Tegra) running on Tegra
Bus 003 Device 010: ID 0955:7045 NVIDIA Corp. Tegra On-Platform Operator

With JP-5.0.2 host shows only:

$ lsusb
Bus 003 Device 010: ID 0955:7045 NVIDIA Corp. Tegra On-Platform Operator

On Xavier running JP-5.0.2 the USB-C console works fine.

Hi @wangliyong @luciferydy @Agtonomy
Please share the information for reference:

1. cat /proc/device-tree/chosen/ids
2. xxd /proc/device-tree/i2c@c240000/ucsi_ccg@8/interrupts
3. xxd /proc/device-tree/i2c@c240000/ucsi_ccg@8/interrupt-parent
ag@orin:~$ cat /etc/nv_tegra_release
# R35 (release), REVISION: 1.0, GCID: 31250864, BOARD: t186ref, EABI: aarch64, DATE: Thu Aug 11 03:40:29 UTC 2022
ag@orin:~$ cat /proc/device-tree/chosen/ids
3701-0000-500 3737-0000-400
ag@orin:~$ xxd /proc/device-tree/i2c@c240000/ucsi_ccg@8/interrupts
00000000: 0000 0094 0000 0008                      ........
ag@orin:~$ xxd /proc/device-tree/i2c@c240000/ucsi_ccg@8/interrupt-parent
00000000: 0000 0014                                ....

Sry for the late reply.

root@dfOrin:~# uname -a
Linux dfOrin 5.10.104-tegra #1 SMP PREEMPT Wed Aug 10 20:17:07 PDT 2022 aarch64 aarch64 aarch64 GNU/Linux
root@dfOrin:~# cat /proc/device-tree/chosen/ids
3701-0000-500 3737-0000-400
root@dfOrin:~# xxd /proc/device-tree/i2c\@c240000/ucsi_ccg\@8/interrupts
00000000: 0000 0094 0000 0008                      ........
root@dfOrin:~# xxd /proc/device-tree/i2c\@c240000/ucsi_ccg\@8/interrupt-parent
00000000: 0000 0014                                ....

nvidia@nvidia:~$ cat /proc/device-tree/chosen/ids
3701-0000-500 3737-0000-400
nvidia@nvidia:~$ xxd /proc/device-tree/i2c@c240000/ucsi_ccg@8/interrupts
00000000: 0000 0094 0000 0008 …
nvidia@nvidia:~$ xxd /proc/device-tree/i2c@c240000/ucsi_ccg@8/interrupt-parent
00000000: 0000 0014


Could you try to remove tegra234-p3737-a04-overlay.dtbo from p3701.conf.common and flash your board again?

Hi,I am often use sdk manager to flash.
I can find and delete tegra234-p3737-a04-overlay.dtbo from linux_for_Tegra/p3701.conf.common。
What should I do next?

thank you!

Please use to flash then.

sudo ./ jetson-agx-orin-devkit mmcblk0p1

1 Like

Tried with OVERLAY_DTB_FILE="L4TConfiguration.dtbo,tegra234-p3737-overlay-pcie.dtbo,tegra234-p3737-audio-codec-rt5658-40pin.dtbo,tegra234-p3737-a03-overlay.dtbo"; in p3701.conf.common.

The USB device mode works now!
The l4t-readme mass storage shows up too, network usb0 works fine.

Hi @luciferydy @wangliyong ,

Sorry that could you guys also share me the result of

sudo i2cdump -y 0 0x56

Please directly share it as a screenshot. If you directly paste it as text, the format may be gone.

Is it okay?

Yes, thanks.

Converted the .dtbo to .dts, it seems only interrupt vector is changed.

Dose it mean removing this overlay wont influence other parts of the devkit?

And thanks a lot for the help!

This is still a WAR and we are still doing some internal check. Will provide the official solution later.