JetPack 6 imx219 MIPI does not work

I use Seeed studio je3011 Jetson Orin development kit to connect MIPI camera imx219, but i failed to load the camera. can you suggest what else to check ?

camera is detected
image
however, got this error

hello muhyin87,

let’s narrow down the issue,
please refer to developer guide, Approaches for Validating and Testing the V4L2 Driver.
please check with V4L2 IOCTL to verify the basic camera functionality.

Hi Jerry,

I did try this, no error but nothing happen. .raw. did I miss something ?
$ v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --stream-mmap --stream-count=1 -d /dev/video0 --stream-to=ov5693.raw

hello muhyin87,

could you please dig into kernel messages to understand the root cause.
for instance,$ dmesg > klogs.txt

Hi Jerry,
here is the log files.
klogs_after_cmd.txt (62.6 KB)
repeated error

hello muhyin87,

it looks request has timed out. I also notice you’re using the samples command-line of ov5693,
could you please have format dumps, $ v4l2-ctl -d /dev/video0 --list-formats-ext, and update those width/height/formats settings within v4l2 command-line accordingly.

$ v4l2-ctl -d /dev/video0 --list-formats-ext,
image

still no luck
v4l2-ctl --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --stream-mmap --stream-count=1 -d /dev/video0 --stream-to=test.raw

hello muhyin87,

could you please confirm what’s the difference with Seeed studio je3011? is it Raspberry pi imx219?
we’ve tested and confirmed IMX219 works normally on Orin Nano Developer Kit with JP-6 DP release version.

Seeed studio je3011 is Jetson Orin Nano developer kit.
does it work with IMX179 ?

what exactly the camera sensor you’re working with.

Hi Jerry, earlier i had a doubt on the sensor that i use, but confirmed it’s IMX219.

I tried jetPack 5.1.3 and using command below. it works, but not with jetPack 6

gst-launch-1.0 nvarguscamerasrc sensor_id =0 ! ‘video/x-raw(memory:NVMM), width=1920 ,height=1080 , format=(string)NV12’ ! nvvidconv ! nvegltransform ! nveglglessink

hello muhyin87,

is it package installation failure?
please try again with…
$ sudo apt-get update
$ sudo apt-get install nvidia-l4t-gstreamer
$ sudo ldconfig
$ rm -rf .cache/gstreamer-1.0/
$ DISPLAY=:0 gst-launch-1.0 nvarguscamerasrc ! nvvidconv ! video/x-raw ! xvimagesink sync=0

did not work. I’ll work with JP5.1.3 for time being. Thanks

hello muhyin87,

since JP-6 is a Developer Preview version. please verify once again when a production quality release is available.
note, next JP-6 public release will be target around Apr/2024.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.