Orin JetPack 6.0 no config for IMX_219 camera

Hi,

I’m a student trying to set up my Jetson Orin (Jetpack 6.0) RC car with a CSI Raspberry Pi Camera V2; when I run “v4l2-ctl --list-devices” it detects a camera, but can’t run the video from /dev/video0

image

I checked /proc/config.gz and it shows “CONFIG_IMX219” as commented out–I read that this is a kernel file and modifying it requires the kernel to be rebuilt–is this correct?

How can I enable the config for the IMX219 camera so I can get video output on my orin?

Thank you

Please enable the imx219 by jetson-io.

Thanks

Hi,

I enabled imx219 in jetson-io for both cam0 and cam1, the IMX_219 now shows video0

image

but I still don’t get image / video output, when I run cheese it still says no device detected.

I ran the following command and it shows that the camera is functioning:

image

but still no video output when testing:

The same camera was tested on a Jetson Nano dev kit and works as expected, so I don’t think the camera is the issue. The cable is brand new and is being detected, so I don’t think the cable is the issue. I confirmed that the cable is oriented correctly because switching the orientation causes the camera to not be detected on a reboot.

What am I missing here?

Thank you for the help

Hi arvind,
I experienced exactly the same problem. I simply reflashed my orin nano and it works smooth… Could you try gst-launch-1.0 nvarguscamerasrc sensor_id=0 ! nv3dsink

sensor id depends on the port you have connected your camera to.

Please copy the log instead screen capture.

Thanks

Hi, I reverted to JetPack 5.1.3 and the camera works as expected without needing to modify jetson-io

This solved my issue

I know why the camera wasn’t working in JP 6.0, it was because I was using the orin via VNC server. I suspect the camera would have worked fine if I tested it while connected to a monitor, keyboard, and mouse.

I know this is the case because I am on JP 5.1.2 (not a typo) and I tested the camera while connected to a display/kb/mouse and it worked as expected, but the same camera does not work when using VNC (headless with GUI passed over network to remote computer) in 5.1.2 also–is there a way to get the CSI camera working while using orin via VNC without a physical display connected to the orin?

Run below command before run the camera.

xinit&
export DISPLAY=:0

Hi Shane,

When I run xinit& I get the following:

I googled and shut down x server by running “sudo service gdm stop” then I ran “xinit&” then “export DISPLAY=:0” (I was connected via SSH when running these commands on the Orin Nano)

After running that I no longer have VNC server running though, and knowing it wouldn’t work I tried to run the camera test and it failed with the same error

I rebooted and VNC server started up again, so I tried the camera one more time and get the same/similar error

This is what I get when I ignore the xserver error and set export DISPLAY=:0

Did I follow your instructions incorrectly? I am still running the Orin Nano headless with VNC server in these examples

I have given up on getting the CSI camera to work with VNC server.

I removed VNC server, restored /etc/X11/xorg.conf and the camera works as expected when connected to a physical display

VNC using virtual display that don’t support by Argus.
You can also us ssh connect to Orin Nano to do it.

Hi, in my above screenshot I SSH’d into the Orin Nano (the screenshots with the black background) and ran the same commands and it gave me the same error

That being said, it sounds the like Argus platform would need to have the camera streamed to have it be visible when using the VNC

I think that answers my question, thank you