Trouble connecting camera module to Jetson Orin Nano

I’ll explain what I’m currently having trouble with.
I’m trying to connect and use a camera module to my “Jetson Orin Nano 8GB,” but I’m running into a situation where the camera module’s code is not recognized even when I connect it to the camera interface.

What I tried was when I connected, I typed the command "ls -al /dev/video0 " into the terminal to display the identified cameras, but nothing was recognized.

On the other hand, sometimes when the camera was not connected, “/dev/video0” was displayed, indicating that the camera was being recognized.

Could you please give me some advice on what other settings are there to properly recognize the camera?

The camera module is adapted from Jetson Orin Nano.
I have attached the actual URL for your reference.

hello omuro.kairi,

had you Running Jetson-IO to configure the CSI connector?
please also gather the kernel messages for checking camera device registration results. i.e. $ dmesg > klogs.txt

1 Like

Thank you for replying, JerryChang.

Sorry for the late reply.

I have attached the text file of the execution results here.
I tried setting up CSI using Jetson-IO as you taught me, using the steps shown in the URL below, but it didn’t work.

Thank you

klogs.txt (70.5 KB)

hello omuro.kairi,

there shows failure for camera device registration.

[   16.396946] imx219 9-0010: tegracam sensor driver:imx219_v2.0.6
[   16.407797] imx219 9-0010: imx219_board_setup: error during i2c read probe (-121)
[   16.424052] imx219 9-0010: board setup failed
[   16.431586] imx219: probe of 9-0010 failed with error -121
[   16.438277] imx219 10-0010: tegracam sensor driver:imx219_v2.0.6
[   16.448984] imx219 10-0010: imx219_board_setup: error during i2c read probe (-121)
[   16.463630] imx219 10-0010: board setup failed
[   16.477040] imx219: probe of 10-0010 failed with error -121

are you using Orin Nano developer kit, or, it’s a customize carrier board?
if you’re using a customize carrier board, you’ll need to apply some changes to make it works, please contact with sensor vendor for further supports.

hello JerryChang,

I am using developer kit.
Is it true that the problem I’m currently experiencing can’t be fixed with my personal settings and I’ll have to send it to a NVIDIA for repair?

By the way, I don’t know if it will help, but the error message and source code are as follows.

error_messege.txt (715 Bytes)

code.txt (271 Bytes)

hello omuro.kairi,

that code did not works due to camera device registration has failed.
please double confirm you’re having correct pin direction of these flex ribbon cable.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.