Jetson orin nano devkit imx219 boot failure

error during boot, without camera attached:
imx219_board_setup: error during i2c read probe (-121)

there was another error which might be related to this:
kernel: tegradccommon module_init failed


I reflashed once, same error. I will try using a bigger sd card(64GB).

more dmesg in case you need it:
jackie@jackie-desktop:~$ more /var/log/dmesg
[ 0.000000] kernel: Booting Linux on physical CPU 0x0000000000 [0x410fd421]
[ 0.000000] kernel: Linux version 5.10.104-tegra (buildbrain@mobile-u64-6289-d7000) (aarch64-buildroot-linux-gnu-gcc.
br_real (Buildroot 2020.08) 9.3.0, GNU ld (GNU Binutils) 2.33.1) #1 SMP PREEMPT Sun Mar 19 07:55:28 PDT 2023
[ 0.000000] kernel: OF: fdt: memory scan node memory@80000000, reg size 16,
[ 0.000000] kernel: OF: fdt: - 80000000 , c0000000
[ 0.000000] kernel: Machine model: NVIDIA Orin Nano Developer Kit

1 Like

What do you mean " imx219 boot failure" ??


Hi Shane,

imx219 errors at boot time, without a camera attached.

This board is brand new. bought 3 month ago, and did not use it until lately.
I ran this line right after booting, “sudo dmesg -H|grep failed”. it returned:

[ +0.006007] tegradccommon module_init failed
[ +0.004267] tegradc module_init failed
[ +0.008396] dce: dce_admin_setup_clients_ipc:529 Get queue info failed for [2]
[ +0.007100] pva: probe of 16000000.pva0 failed with error -110
[ +0.007429] nvdla: probe of 15880000.nvdla0 failed with error -110
[ +0.007428] nvdla: probe of 158c0000.nvdla1 failed with error -110
[ +0.000566] imx219 9-0010: board setup failed
[ +0.005157] imx219: probe of 9-0010 failed with error -121
[ +0.015504] imx219 10-0010: board setup failed
[ +0.006512] imx219: probe of 10-0010 failed with error -121

I have reflashed two sd cards using the latest image: “JP511-orin-nano-sd-card-image”. same result.

Thank you

Those message tell unable communicate to IMX219, suppose it could be HW issue.


still under warranty, so how can I get a replacement? Thank you

It seems to me the previous reply is indicating these errors may be normal if no camera is attached. Have you tried booting with a camera attached to one of the CSI connectors to see if the errors go away? If you don’t have a imx219 camera available I suspect it is safe to ignore these errors and continue to use the device.

I would agree however that it would be helpful if the OS could detect the “no device connected” condition and simply ignore it without reporting an error. A question of priorities I suppose.

Actually I don’t think it is an issue to connect camera back.

Please just use sdkmanager to reflash the board first. (not sdcard image)

The situation is you saw some logs on the screen and you panic because you saw some errors from it.
In this situation, doing full software reset first before next step. Maybe they are not related to your issue at all.

For example, I can see imx219 error from my board too but my board can boot up without error.

1 Like

The reason I posted this issue was because camera test failed; when I ran this line,
as in this link (Taking Your First Picture with CSI or USB Camera | NVIDIA Developer), the board became dead.

Hi Wayne,
can you send me the link about using sdkmanager to reflash the board?
It seems Windows not supported per System Requirements :: NVIDIA SDK Manager Documentation

Yes, windows does not support. Need to use native ubuntu 18.04 or 20.04.

Also, you could dump the full log from serial console first…
It is actually a conflict comment to your own comment when you said “my board is dead” and “please check my dmesg”… if your board is really dead, you won’t dump dmesg… Thus, I don’t think the board is dead…

not conflict. I got the log without attaching the camera. check my previous messages

You may need to use serial console to dump log for camera connected case.

full dmesg log is attached.
dmesgJackieLi071823 (74.4 KB)

Again, I got this log right after booting with nothing attached from a brand new board.

Please, tell me the implications of the “failed” messages.
one implication is camera test fails, what else? I paid full price and don’t deserve this.

To me and per ShaneCCC, the board is defective.


I think there are some misunderstanding.

ShaneCCC’s point is there could be a hardware issue like you don’t connect the camera or the camera has some hardware problem.
But since you really don’t connect the camrea, of course there would have such log printed…

We are not talking about the board has defect.
I didn’t mean this board 100% won’t have hardware problem. The point is just it seems you misunderstood the case.

If you want to look into why the board cannot respond when you connect camera, you need to dump the serial console log as my previous comment…

From your dmesg, it looks like this board is mostly fine.

please stop wasting my time, the evidence is right there. in the worst case scenario, this would go to court.

If you don’t connect the camera the imx219 error message showing is as expected and won’t cause any problem.
What I mean HW problem is talking the camera HW problem.


what about the rest of the “failed” messages. this is brand new board, $600 from my own pocket. My offer is send me a replacement and I send the defective one back to you. Otherwise, I will escalate all the way to the court.

Please clarify what’s your problem clean.
Looks like you have already boot to the OS and able enter command to check the kernel message.
If your problem is unable boot the Ubuntu Desktop(GUI) please get the UART log for as to check.


The camera supported by default is Raspberry Pi camera v2. If you use cameras from other vendor, you would need to check sensor driver programming guide to program device tree according to the camera module.

Hi, I’ve been dealing with the same issues and have spent hours going through forum posts and other resources to try to figure it out with no prevail. I have an imx219 camera, I’ve tried erasing and flashing the SD card multiple times, I’ve tried booting the board with and without the camera connected to the CSI port. I see on a lot of posts you guys link the driver page but don’t really give any direction of where to look. I also don’t have access to a Linux machine besides the Jetson Nano I bought to install the SDK manager. What should my next steps be?