Imx219_board_setup: error during i2c read probe (-121)

Hi - I just received my jetson nano 2gb a few days ago and I have not been able to establish a connection with a camera through the MIPI CSI-2 port. I’m using an HDMI to CSI-2 module and I’ve verified connectivity and operation with a Pi development board so the camera or the module itself I don’t think is the issue.

During boot up, these messages appear which I think are related to the camera device.

imx219 6-0010: imx219_board_setup: error during i2c read probe (-121)
imx219 6-0010: board setup failed
cp: not writing through dangling symlink 'etc/resolv.conf'

when I run ls /dev, video0 is not present.

I have installed v4l-utils and it still hasn’t solved the issue.

Here’s some of the output from dmesg

[    1.206213] imx219 6-0010: tegracam sensor driver:imx219_v2.0.6
[    1.229503] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x10
[    1.229579] imx219 6-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.229606] imx219 6-0010: board setup failed
[    1.904675] cgroup: cgroup2: unknown option "nsdelegate"
[    4.214092] tegra_cec 70015000.tegra_cec: timeout in tegra_cec_native_write_l:172.

Any ideas on what could be causing this?

Thank you
Jamie

Have you connect the imx219 sensor board? If not you need to update the device tree and driver for your “HDMI to CSI”

Thanks for your response. I don’t have an imx219 sensor board so there’s the problem. Ok. I’m new to this so not sure how to update the device tree and driver. It looks like this post HDMI 2 MIPI CSI Device Tree has some info. Is there documentation available that explains the process?

Thanks in advance!

Check below document and sensor programing guide.

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Fkernel_custom.html%23

1 Like

I encountered the same error message on the initial boot of my nano 2GB. I have attached to it an HDMI monitor, keyboard, mouse, and ethernet. After a while, it continued to boot and then restarted but then it failed a couple of steps. Here are some images. Unfortunately, they are in reverse order. Is this maybe a corrupted file that I downloaded?

Even the sensor i2c failed ack the system should be able boot to system.
If it’s file corrupted relfash the image should be help.

Should I just download a new copy?

Could you try to use sdkmanager.

https://docs.nvidia.com/sdk-manager/install-with-sdkm-jetson/index.html

https://developer.nvidia.com/nvsdk-manager

So I need to use linux to install because it is a debian file?

Yes,

I have a virtual environment running ubuntu and I successfully installed the sdk manager. Now the issue is that it cannot see the jetson device when I connect with the micro USB. Under device manager, I do not see “USB serial device”

The host windows machine cannot see it

For SDK Manager, you’d better use a native Linux machine not a VM.

Ok, I don’t have a native linux machine besides a raspberry pi 3. Will that work? Also, shouldn’t my windows machine at least be able to see the nano? I understand that I will want to use a native Linux machine, the second question is completely independent from the first. I am just concerned that it cannot communicate with another device.