IMX219-160 camera I2C issues

When I plugin my camera module and boot the Jetson it is not recognized.

Error message:

imx219_board_setup: error during i2c read probe

I am not sure what can cause this. I tried to re-attach the cable to the camera and board several times. No other devices except for the WIFI module are present

Is there something I can do software wise? I can login to the console just finde and “dmesg” shows me the error.
One side effect is also that as long as this i2c error persists (camera attached) the WIFI NIC is not available (not present).

Thanks in advance.


Nano only support Pi v2 imx219 by default image if you didn’t use this you need to customize the kernel/DTB to support it.

Thank you for your quick reply.

I use the image from here:

Is this the default image?

Yes, that should be working for the imx219 Pi V2 camera.

Sadly it does not.

The only thing I did not try so far is to reinstall the SD card image with the camera already attached to it and go through the initial oem-config process again. However I somehow doubt that this will fix the issue. Linux normally detects HW quite well without reinstall / config.

I am not sure if the error can be traced back to a faulty cable or something since dmesg shows that the device recognized the imx219-160 camera

I believe it could be HW or connect problem cause it.

Thanks. I thought it as well. I tried some more yesterday and couldn’t get it to work. So it could be really a hardware fault. What I also noticed is that the camera module itself (soldered components) does look different to the product description pictures.

Anyway I will send the camera back and try with a USB device.