Pi Camera v2.1 doesn't work on my Jetson Nano

Hi,

My Pi Camera v2.1 is not recognized by the Jetson Nano even though it is connected to the MIPI CSI-2 connector (I checked multiples times already). I tried both connectors without success.
I get this error when trying the hello_camera notebooks for CSI camera:

"ls: cannot access '/dev/video*': no such file or directory"

When digging a bit more into dmseg in can see those lines:

[    1.245959] imx219 7-0010: tegracam sensor driver:imx219_v2.0.6
[    1.269252] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x10
[    1.269333] imx219 7-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.269364] imx219 7-0010: board setup failed
[    1.269426] imx219: probe of 7-0010 failed with error -121
[    1.269809] imx219 8-0010: tegracam sensor driver:imx219_v2.0.6
[    1.279114] extcon-disp-state extcon:disp-state: cable 47 state 0
[    1.279116] Extcon AUX1(HDMI) disable
[    1.293085] tegra-vii2c 546c0000.i2c: no acknowledge from address 0x10
[    1.293161] imx219 8-0010: imx219_board_setup: error during i2c read probe (-121)
[    1.293189] imx219 8-0010: board setup failed

I’ve seen a lot of post about the same issue (or very similar with for example imx219 6-0010 instead of 7-0010) but was unable to find a solution thus opening this one.

Hardware:

  • Jetson Nano B-01 (the one with two camera connectors)
  • Pi Camera v2.1 (official one, I verified already)
  • MicroUSB cable as power supply

I don’t have a DC barrel jack power supply and use microUSB as my main power supply, could this be the reason it doesn’t work? (I’m using Jetson Nano in 5W mode and it works as intended)

Your nano can’t detect imx219 over i2c. Did you check your imx219 cable, maybe your connect wrong.

Connect like this image:
https://i.ebayimg.com/images/g/1tcAAOSwCatc7Kjc/s-l1600.jpg

just a quick note that I do not have an issue with this, also using microUSB for power. In fact both Rpi 2.1 camera and IMX219 work. One thing to check is that the Rpi camera cable needs a flip. the contacts must face towards the middle of the Jetson board, not towards the edge.

It’s cold be the HW connection problem.
The bus number is 7 and 8 if it’s two camera connectors version.

It was an hardware problem with my camera. I send it back and got a new one. Now it works, thanks !