Orin nx 16G imx219 Camera failure

  • Images could not be acquired using the imx219 camera on Orin nx.
    The phenomenon is as follows:

The following multicast commands are used:
cameraTest-2.sh (762 Bytes)
Program run log:
第一次播放.txt (2.9 KB)
The system will prompt : bwmgr API not supported

v4l2-ctl --device /dev/video0 --stream-mmap --stream-to=frame.raw --stream-count=4
video0-.log (10.8 KB)

v4l2-ctl --device /dev/video1 --stream-mmap --stream-to=frame.raw --stream-count=4
video1.log (15.2 KB)
Block on the terminal after the command is executed

hello 1912680640,

may I know which JetPack release version you’re using.
we’ve test this locally and rbpcv2-imx219 it’s worked normally on Jetpack-5.1.

I followed the instructions in the manual.
Is there a way to swipe directly with sdkmanager?
The Jetson Xavier NX mirror pack and the Orin nx mirror pack seem to be the same to me.
Forgive my ignorance, but I really don’t know how to find the latest JP 5.1 release.

please download SDK Manager - NVIDIA Developer for Jetpack installation.

I have downloaded it, but there is no option for Orin nx

NV official image package is already integrated with imx219 driver? I don’t think we need to do it ourselves?
Is that right?

hello 1912680640,

sorry, am not notice that you’re using Orin NX.
you may still working with the Jetpack-5.1 release version, and please execute script file, l4t_initrd_flash.sh for flashing Orin NX.

please see-also $OUT/Linux_for_Tegra/tools/kernel_flash/README_initrd_flash.txt

hello 1912680640,

yes, IMX219 camera driver (also others) is built-in with native Jetpack release image.
you may execute Jetson-IO to configure CSI.

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 jetson-orin-nx-devkit-16gb internal

Above are the commands I used,I got it from the Release Notes Version 35.2 EA documentation and I think it should be reliable。

I uploaded the latest log in initrdlog. Does it look normal? The system will be up after flash is successful.
flash_1-10_0_20230308-165852.log (86.5 KB)

I also want to make sure if this version image can be used normally?

yes, JetPack 5.1 is a production quality release and brings support for Jetson Orin NX.

Okay, I see. I’ll try to find other reasons.

@JerryChang When I burn the program to the 3768 board of NV, the DP interface does not display the desktop, and there is no startup information, but everything is normal in DEBUG, do I need to set it to DP display somewhere?

hello Cecelia,

please give more details of what’s the environment setups.
are you using native Jetpack-5.1 with Jetson Orin NX developer kits?
please also share your steps for flashing the board.

I used Jetpack-5.1.

The following is my entire writing process, which is operated by referring to Partner Release Notes Version 35.2.1.

The burn write command is
sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 -c tools/kernel_flash/flash_l4t_external.xml -p “-c bootloader/t186ref/cfg/flash_t234_qspi.xml” --showlogs --network usb0 jetson-orin-nx-devkit-16gb internal.
I uploaded the burned log in the Linux_for_Tegra/initrdlog directory
flash_1-10_0_20230313-104215.log (86.8 KB)
In addition, there are some error messages printed in the terminal, but they are not recorded in flash_1-10_0_20230313-104215.log. I copy them to log.txt
log.txt (11.4 KB)

hello Cecelia,

we’ve tried locally, Orin NX (i.e. QSPI+NVMe (For P3767 + P3768)) it works normally with DP display monitor.
is it possible for changing another display monitor for confirmation?

Ok, thank you for your reply. I’ll try to change the monitor.