Jetpack 6 & jetson inference

Cloned jetson-inference
docker/run.sh
looking for jetson-inferencer36.3.0

docker: Error response from daemon: manifest for dustynv/jetson-inference:r36.3.0 not found: manifest unknown:
Will there be a version for jetpack 6?

Hi @paulrrh, I just pushed the dustynv/jetson-inference:r36.3.0 container image, can you try it again?

Thanks for reply,
have executed
docker/run.sh

which built the image
there is no build directory hence no
cd build/aarch64/bin

EDITED ON 10 MAY
I have found directories in docker image
/opt/jetson-inference/build/aarch64/bin

Hi Dusty_nv
built container with docker/run.sh

The following does not work as there is no BUILD directory in container
$ cd build/aarch64/bin
$ ./video-viewer /dev/video0
$ ./imagenet images/jellyfish.jpg images/test/jellyfish.jpg
$ ./detectnet images/peds_0.jpg images/test/peds_0.jpg

(press Ctrl+D to exit the container)

Hi @paulrrh, in container they should already be installed under /usr/local/bin, so you don’t need to refer to the program names with ./ in front (i.e. you should just be able to run video-viewer --help)

Hi Dusty_nv
Thanks for you help and reply
Sorry about the confusion, I cut and pasted part of hello world to my last reply.
I’m aware of ./ before program does not work and has’nt worked for at least 18mths,
also you can run the programs without going to any directory. My point is I have been using jeston inference on xavier nx for the last 2 years and also on Agx orin before jetpack 6.0 which I have now freshly installed and installed jetson-inference. The file structure of jetson-inference is not the same with jetpack 6. The only reason I am using jetson-inference is I was familier with the software on both machines which worked the same prior to jetpack 6 hence this conversation. I am fully aware than jetpack 6 is in its infancy and not everything will compare with earlier versions and I don’t have a problem of changing directories from ((/build/aarch64/bin) to (/usr/local/bin)) depending which machine I am using.
I will now spend some time re-building jetson-containers as I deliberatly wiped the system to install jetpack6.
Thanks again for your support, I will no-doubt be in touch in the future.
paulrrh

Just a quicky
I noticed the keyboard response in jetson-inference is delayed when typing.

Hi @paulrrh, that’s interesting - which program are you noticing that on? Are you meaning inside container, or from desktop GUI? I’m not sure its related to jetson-inference itself as I can’t recall there really being keyboard I/O in those programs itself.

Strangely I have recently noticed delayed typing on my 22.04-based x86 desktop system, apparently some GNOME issue…

Its inside the container although I have just tried it and the delay was not as bad as earlier.
I have had few problems (see starting ubuntu 22.04) and have had to reflash jetpack 6 the problem was the same as before the re-flash.