Jetson AGX Orin: riva_init.sh Fails

Hardware: Nvidia Jetson AGX Orin Development Kit
Operating System: Ubuntu 20.04.4 LTS
Riva Version: Riva Skills Quick Start 2.2.1
Jetpack Version: 5.0.1
Docker Version: 20.10.12 (nvidia-docker installed)

Hello,

I’m trying to follow the Riva Skills Quick Start tutorial, but unfortunately I get already stuck when running the riva_init.sh which leads to following output (this is the full script log):

Please enter API key for ngc.nvidia.com: 
Logging into NGC docker registry if necessary...
Pulling required docker images if necessary...
Note: This may take some time, depending on the speed of your Internet connection.
> Pulling Riva Speech Server images.
  > Pulling nvcr.io/nvidia/riva/riva-speech:2.2.1-server. This may take some time...

Downloading models (RMIRs) from NGC...
Note: this may take some time, depending on the speed of your Internet connection.
To skip this process and use existing RMIRs set the location and corresponding flag in config.sh.
Error response from daemon: No such container: riva-models-download
Error in downloading models.

I did already try to run it again after a riva_clean.sh run with the same result.
My config.sh can be found here: config.sh (13.3 KB)

Only ASR is enabled in de-DE language, but I also tried it with en-US again with same result.

What am I doing wrong?

Best regards and thanks in advance
Andreas

Hi @ab-tools

Thanks for your interest in Riva,

Apologies you are facing issues,

I will check on this issue/error further with the team and get back,

Thanks for your patience

Thanks, @rvinobha, appreciating your quick reply!

I’ll be waiting then for further feedback from your team on this issue now.

Best regards and thanks for your support
Andreas