Jetson AGX ORIN won't boot

During working, my jetson agx orin 64gb dev kit shut down. It doesn’t start now. I have tried to change monitors, adapters and still nothing.
When I connect it to host, it doesn’t recognize device.

Hi antoninaignjatovic98,

What’s your Jetpack version in use?
Could it boot successfully before?

Please refer to the following instruction to capture serial console log for further check.
NVIDIA Jetson Orin - Serial Console - RidgeRun Developer Connection

Hi Kevin,
Thank you for your answer. Jetpack is 5.1.1.
It was working without problem for almost 2 months but yesterday shut down while working and now won’t boot.
I will check the link you provided.

Do you run any application or any action might cause the boot issue?
Okay, please provide the full serial console log for further check.

None application was run when it shut down. How can I get full serial log when the Jetson won’t turn on?

I have followed instruction from the link you sent but there is a command which is not recognized. Please check attachment.

Please just use minicom to setup the UART from your host PC to setup the serial console.

$ sudo minicom -D /dev/ttyACM0 

Yes, this works now, but what is next step? What next should i do?

To be honest, never used this “minicom”. What should i configure next?


Reboot your device… log will print on mincom, copy all the things into a text file and attach that file here…

If it got stuck somewhere, we will know…

minicom is just a tool to dump boot up log. If it successfully boots into system, then it can operate the system as a console too.

Here is what i got when u use minicom and booting up system on jetson.

log.txt (8.87 KB)

This is log which i get when i connected via UART, starting jetson and watching on minicom.
log.txt (8.9 KB)


please use the correct baud rate and dump log again.

minicom -D /dev/ttyACM0 -b 115200

Still the same problem, still the same result from log… Any solution or whatever, just to fix this?
log.txt (14.1 KB)

Prepare another x86 host pc. Install sdkmanager and let sdkmanager flash your jetson.

You have to put the board into recovery mode so that host can detect your board.

I’ve been trying to put the board in recovery mode for two whole days. Pressing the center button, then the left button and releasing both at the same time, right?

I tried, but still nothing. I can’t flash jetson, because it won’t recognize the board.


Nope. It depends on the status of the board. I never memorized something like “center button” or “left button”.

  1. There are 3 buttons. Recovery, reset and power.

  2. If the board was already powered on. Press and hold recovery. Then press reset, release reset and then release recovery.

  3. If the board was not powered on, replace the the reset button in (2) to be power button.

Also, please make sure you use the correct type C port… only one port on the board could be used as flash port.

And your host PC cannot be VM. Your usb cable needs to have data line but not just power line usb cable…

If you don’t know which type C port is correct, refer to the developer kit document here.

I tried the same, but still without success. If the board is on, then the button in the middle (recovery) and then the right button (restart) or if the board is turned off, then the button in the middle and the left button (power). I also checked if I’m using exactly that C port and yes, I’m certainly using exactly the right one. Likewise, I use the cable that came with the device, which serves not only for power supply, but also for data transfer and flashing. It’s not the first time I’ve flashed a device, but this time for some reason it won’t even though I’m doing everything the same as before. If you have another solution, I would really appreciate it. Thank in advance.