Jetson Inference Live camera demo cannot open camera

I have isntalled Jetson inference on my jetson nano, everything went fine so far and even did the sample jpeg recognition demo. Now i went ahead and tried the live camera demo but it would seem like it could not open the camera.

The camera is a IMX708 installed via driver using this guide, no problem with the driver and am being able to view the camera using the following gstreamer command

gst-launch-1.0 nvarguscamerasrc sensor-id=0! "video/x-raw(memory:NVMM),width=4608,height=2592,framerate=14/1" ! queue ! nvegltransform ! nveglglessink

but when i tried as per the jetson live inference demo

cd jetson-inference/build/aarch64/bin
./imagenet.py csi://0


And this keep reapeating over and over,

I also tried ./imagenet.py /dev/video0 because v4l2-ctl says its present


Any ideas for a fix ?

Hi,
please try this command and see if it runs successfully:

gst-launch-1.0 nvarguscamerasrc sensor-id=0 ! "video/x-raw(memory:NVMM),width=4608,height=2592,framerate=14/1" ! nvvidconv ! video/x-raw ! fakesink sync=0

And do you use Jetpack 4.6.4? This is the latest version for Jetson Nano.

@thesis.finals333 there is an error here about the framerate requested, try running it with --input-rate=14 . And if that doesn’t work, you may edit the GStreamer pipeline that gstCamera.cpp creates here: