Jetson-inference on jetson nano cobot

I have a JETANK waveshare cobot with Jetbot image installed on its Jetson nano. I have tried all my best to run the following:

import jetson.inference
within the installed Jupyter notebooks with no success. Always get the same error message No module named jetson.

I did installed jetson-inference several times using the following code using Putty:

git clone --recursive GitHub - dusty-nv/jetson-inference: Hello AI World guide to deploying deep-learning inference networks and deep vision primitives with TensorRT and NVIDIA Jetson.
cd jetson-inference
mkdir build
cd build
cmake …/
make -j$(nproc)
sudo make install
sudo ldconfig

then whenever try to import it on the jupyter notebook it gives me the same error.
Can you help me with this issue please? It would be hugely appreciated.


Which Python version is used in your environment?
If Python 3.8 is used, please try the suggestion below:


@m.h.s.a.farrag can you also confirm that you are able to import jetson_inference module outside of JupyterLab or run any of the Python samples like,, ect?

python3 -c 'import jetson_inference'

BTW, import jetson.inference is deprecated (in lieu of jetson_inference), but it should still work with a warning message.

Thank you for your reply,
The installed version is 3.6.

Thank you for your reply, hopefully, I can get through this issue.
Yes I can import jetson_inference module outside of JupyterLab with no issues but I can’t do the exact same in the Jupyter notebook

Hi @m.h.s.a.farrag, I installed JupyterLab into a jetson-inference container on JetPack 4.6, and was able to import jetson_inference. Did you select Python3 when you created the Jupyter notebook?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.