ModuleNotFoundError: No module named ‘jetson’

Hello.I need to import jetson_inference for my programm, but cant.(I tried to do it in python 3.7.1 and python 3.6.15 but i couldnt)

Also i tried to follow these instructions :, but i couldnt complete the installation:

Because it is really already exists:

My qustion is how can i import jetson_inference for my programm?


Could you try it with python 3.6 on Jetson natively without using conda?

Thanks for your reply. I installed python3.6, but, unfortunately it didnt help.

But i noticed, that now i can execute command “import Jetson” without any errors (check the last line on the image).Unfortunately i still cant execute command “import jetson_inference/import jetson.inference/import Jetson_inference/import Jetson.inference”.What can i do ?

Python3.6 is not default python (default is python 3.7) in my system and to run programm with python 3.6 i launched it manually by command: “python3.6”.Is my problem associated with this ?If so, how can i make python 3.6 default for my system?

I followed the instructions : and completely reinstall jetson-inference.As a result i could import it, but i still have problems.

Problem with numpy : I already have numpy, but i have warning: “completed without Numpy array …”. I executed command: “sudo apt-get —reinstall install python3-numpy python-numpy” and reinstalled jetson-inference, but it didnt help.

Problem with pytorch: it seems i dont have pytorch, but i am competly sure, that it was installed with jetson-inference, because i saw green window with pytorch install options in my therminal during jetson-inference installation .

I have 3 questions:
1.How can i solve problem with numpy ?
2.Is it possible to import jetson_inference in conda venv ?If so, how can I do that ?(I installed jetson-inference directly in the venv folder, but it didnt help)

3.Why pytorch wasnt installed with jetson-inference and how can i solve problem with pytorch ?

Do sudo apt-get install python3-numpy and then re-run these build steps:

cd /path/to/jetson-inference/build
cmake ../
sudo make install

Haven’t tried this, but it installs the Python extension modules under /usr/local/lib/python3.6/ so probably not.

Difficult to tell without seeing the log. Does pip3 show torch show anything? You can also use the jetson-inference docker container which already has it installed.

Thanks for your reply.
1.I tried this, but ,unfortunately, it didnt help, i still have the same problem.I have 2 python versions in my system : python 3.7 as default and python 3.6. To run programm with python 3.6 i launched it manually by command: “python3.6”.Is my problem associated with this ?What if command “sudo apt-get install python3-numpy” installed numpy for python 3.7 and didnt install numpy for python 3.6 ?If so how can i set python 3.6 as default ?Could you explain me please how does the system works if i have 2 (or more) versions of python installed?Does it install specific version of numpy for each of them or for only one ?

2.Could you tell me please, how to install the specific version of python (python 3.6.15) without conda ?(If i cant import jetson_inference in my venv with specific version of python. i have to install python 3.6.15 on the Jetson natively, without using conda)

3.Could you tell me please, where can i get jetson-inference docker container with installed pytorch ?(I installed it from here :

You can set the versions of Python that jetson-inference looks for when building the bindings here:

You can install Python 3.6 wheels for PyTorch from: PyTorch for Jetson
Just pick one for JetPack 4 (up to PyTorch 1.10) and use the right version of pip when installing it

See here for running the jetson-inference docker container:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.