Jetson Nano Object Detection Tutorial Issue

Hi,

following the Nvidia tutorial from youtube to test the Jetson Nano

NVIDIA Developer - Real-Time Object Detection in 10 Lines of Python Code on Jetson Nano

I followed the instructions until the sample inference is performed, I got this error message:

felipevw@felipevw-desktop:~/jetson-inference/build/aarch64/bin$ ./detectnet-console.py images/peds_0.jpg output_0.jpg
Traceback (most recent call last):
File “./detectnet-console.py”, line 24, in
import jetson.inference
ImportError: No module named jetson.inference

Although when I run python I got:

felipevw@felipevw-desktop:~/jetson-inference/build/aarch64/bin$ python3
Python 3.6.9 (default, Nov 7 2019, 10:44:02)
[GCC 8.3.0] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

import jetson.inference
jetson.inference.init.py
jetson.inference – initializing Python 3.6 bindings…
jetson.inference – registering module types…
jetson.inference – done registering module types
jetson.inference – done Python 3.6 binding initialization

I had to install jetpack manually from the nvidia webpage because I did the manual setup of the Jetson. I redid the proces many times and with git clone -b python command but still nothing.

Any kind of idea what I a missing?

Thanks in advance for any kind of advice

Hi FelipeVW, can you try running this from your ~/jetson-inference/build/aarch64/bin directory?

$ python3 detectnet-console.py images/peds_0.jpg output_0.jpg

You shouldn’t need to clone the python branch of jetson-inference anymore, because it has been merged into master for a long time and hasn’t been updated since then. So you can drop the ‘-b python’ from your git clone command. If you continue having problems, you may want to re-clone master.

Also, make sure do you a ‘sudo make install’ followed by a ‘sudo ldconfig’.

Yes it worked perfectly thank you.
Really helpful tutorials by the way