Jetson-inference TX2

Hi, please, very upset…
Jetpack: 3.3
Ubuntu: 16.04
I followed step by step https://github.com/dusty-nv/jetson-reinforcement

ERROR when running detectnet-camera or imagenet-camera

./detectnet-camera: error while loading shared libraries: libjetson-inference.so: failed to map segment from shared object

I’ve run into build: cmake …/, make, make install

Please can you suggest any action to solve error??
many thanks

Hi,

I just check the jetson_inference sample with JetPack3.3 on TX2.
All works correctly without error.

Could you follow these commands and try it again?
https://github.com/dusty-nv/jetson-inference#cloning-the-repo

$ git clone https://github.com/dusty-nv/jetson-inference.git
$ cd jetson-inference/
$ mkdir build
$ cd build/
$ cmake ../
$ make
$ cd aarch64/bin/
$ ./detectnet-camera

Thanks.

Hi,
thanks for the suggestions.
Yes, I was following step by step the web jetson-inference, it’s not working.
I’ve bypassed reinstalling the Jetson TX2 Developement Kit as from green field.
I’m confirm that now the reinstalled Jetpack 3.3, with Ubuntu 16.04 is working.

My doubt is that: CTI-L4T-V120 that is ConnectTech “L4T r28.2x” package for Orbitty Carrier Board is missing something as well as jetson-inference is not compilable as well as parts of jetson-reinforcement.

Back to Nvidia jetpack3.3 now all is compilable and working but “jupyter notebook” / ipython / pytorch.

I’m still having problems with these compiling.

I’m investigating, something must be reviewed.

Hope some help.

Thanks and regards

Hi,

Jupyter and ipython are unstable on Jetson platform.
But you can convert it into pure python script to make it work.

For pyTorch, you can use this script to build it from source:
https://github.com/dusty-nv/jetson-scripts/blob/master/pytorch_jetson_install.sh

Thanks.

You dont need jupyter for jetson-inference - it’s for using Tensorflow.

Hi,

I’ve been able to compile the whole tutorial/demo reinforcement using :

  • Developer Kit Jetson TX2
  • JetPack 3.3

Even if I tried some different attempts, I can try to share my last succesfull experience with anybody (give me time to answer, please).

About Jupyter Notebook it’s working just installing libzmq3-dev:

sudo apt-get install libzmq3-dev

All is ok.

I’ve been able, after some attempts, to make working:

  • OpenCV 3.4.3 new installation in place of JetPack OpenCV: only with USB stereo cam
  • jetson-inference with all detectenet-cxxxx etc…: only with CSI camera
  • jetson-reinforcement with all the examples jupyter notebook, python, gazebo, crunch, fruit, (I’ve not tested/interested to LUA)
  • Caffe install as from Jetsonhacks

Still not working, but hope on the way:

  • Yolov3
  • Visionworks with real time camera
  • tf_trt classification
  • python camera capture by jkjung-avt

When I use the same procedure to flash emmc for Orbitty with “connecttech” custom <<flash.sh orbitty mmcblk0p1>> I cannot make working all the previous demos, something doesn’t work properly and errors are raised.

My conclusion is that:
When we deploy our apps/firmware to JetsonTX2-Orbitty I think that we must pay attention and something should be rebuiilt.

What do you actually want to do with the Jestson TX2 - have you any particular task?

Yes, you are right I have an important prototype-project at present to test and realize, and some others I have to propose to customers.

Before starting, I need to exploring the full environment and what’s better than modifying the Demos and Tutorials that do work and correct what do not work.

Finally, I need to deploy my application to a small factor like Orbitty allow, but I need to understand how to set up a Development machine and how to transfer to a Deploy machine with safety.

Thanks for any support, I hope to provide the community with sharing my experiences.

My best to all