Jetson-io generated custom dtb affects injection of serial number into DTB

Hello,

Please find device information:

 head -1 /etc/nv_tegra_release
# R32 (release), REVISION: 3.1, GCID: 18186506, BOARD: t210ref, EABI: aarch64, DATE: Tue Dec 10 06:58:34 UTC 2019

There is an issue I have with DTB generated by jetson-io. The tool generates new custom DTB file and adds it as part of new configuration inside /boot/extlinux/extlinux.conf. Requested aud_mclk and i2s1 do work after this procedure.

But I encounter an issue as soon as I start loading DTB using FDT from extlinux.conf. /proc/device-tree/serial-number disappears. Even though bootloader doesn’t report any error and tells that it has added serial-number to DT.

[0004.533] Plugin Manager: Parse ODM data 0x00094000
[0004.545] shim_cmdline_install: /chosen/bootargs: root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyS0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 sdhci_tegra.en_boot_part_access=1
[0004.562] Add serial number:032511xxxxxxx as DT property

Actually it is not being added to DT.
I’m aware that I can read serial number from EEPROM, but my case is specific. /proc/device-tree/serial-number is required by 3rd party library which I don’t have access to and can’t change it.

Another thing I’ve tried is to flash the custom DTB generated by jetson-io into partition using
sudo ./flash.sh -r -k DTB without having to add custom dtb into extlinux.conf.
It fixes serial number issue, but i2s1 and aud_mclk do stop working, which is weird. I’ve double checked it flashes custom DTB by adding my custom parameter and reading it and if I load the same custom DTB as FDT i2s1 and aud_mclk start to work but I lose serial number.

Please advice.
Thank you.

Please do full flash and also try to update to new release.

The purpose of using full flash is because “-k DTB” only update the “kernel” dtb partition. But cboot dtb is in separate partition.

And the reason for new release is rel-32.3.1 is kind of old.

The issue was solved by using Jetpack 4.5 instead of 4.4 for flashing. /proc/device-tree/serial-number is being injected correctly, even into FDT DTB.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.