Jetson-io mcp2515 spi CAN. compatible hardware configuration error

I just flashed Jetpack 4.6 to SD card and booted up. I used Jetson-io.py tool to try to configure MCP251x hardware on the 40 pin header. “MCP251x CAN Controller” is listed under “configure for compatible hardware”. When selected:

FATAL ERROR!

Failed to get pin number for node
/fragment@2/__overlay__header-40-pin-pinmux/pin27/!

Press any key to terminate

When selecting other compatible hardware, this error does not occur. This error occurred with the same image flashed to a different SD card.

Why doesn’t this work?

Hi! Yes, this occurs on Jetpack 4.6 as it was mentioned here
However, this error doesn`t occur on Jetpack 4.5 and 4.5.1, yet, canbus will not work out of the box, you have to do some manipulations as described in this message
But even if you managed to launch can bus following this guide, be careful, I found a bug when Jetson is reading CAN frames IDs higher than 0x400, as I mentioned here
I would be really obliged if you tell me if this bug occurs on your Jetson Nano too.

1 Like

I used a different dts file, but got it to work following your link. I created the .dts by modifying the seeed studio one for the correct pins and changing all occurances of 2518FD to 2515 (@andrew_h 's advice). I don’t have any issues yet sending and receiving high frame IDs (731 comes across as 731). I’m using this waveshare 2 channel board. For what it is worth, I have attached my .dts and note that I executed the following to set it up:

sudo modprobe can
sudo modprobe can_raw
sudo modprobe mttcan
 
sudo ip link set can0 type can bitrate 500000
sudo ip link set up can0
sudo ip link set can1 type can bitrate 500000
sudo ip link set up can1

2xMCP2515-spi0.dts (4.8 KB)

Do you have the correct termination, etc?

1 Like

Thank you for your dts file, I tried to enable my MCP2515 with it and got the same result with wrong IDs and I am sure my hardware is fine (tested it on Raspberry).
Can you please tell which kernel and Jetson Nano board version are you using?
Mine are 4.9.201-tegra, Jetson Nano 4GB B01.

My issue was SPI frequency and signal integrity on my extension board issue, when I set SPI frequency to 2MHz, error disappeared.
.